Jump to content
RESET Forums (homeservershow.com)

DSM 6 Issues & Fix's: BTSync & Plex


ShadowPeo

Recommended Posts

ShadowPeo

Just thought I would post up this information (it is available at the respective sites/forums) I have just aggregated it here to help others.

 

Upon going to install the DSM 6 update over the past couple of days I ran into a couple of issues.

 

Trying to run the update with Plex or BTSync running gives errors stating they are not compatible, and depending on the version this is the case.

  • These versions I have confirmed to be working, both were downloaded on the 23/04/2016 and one would thing subsequent versions would also work.
  • These packages were downloaded from the publishers sites, NOT from the package centre as that is out of date
  • These are for AVOTON series processors I cannot confirm compatibility with other processors at this point (I will be able to confirm BTSync next week on a previous generation processor but those upgrades are not scheduled to happen until Tuesday/Wednesday)

 

Plex Media Server: 0.9.16.5.1966-81a3bf0

BTSync: 2.3.6-1

 

Run the updates BEFORE you upgrade DSM

 

The compatibility error ONLY occurs if the package is running, if it is stopped it does not occur so no need to uninstall completely

 

With Plex there was an issue with some releases prior to the one I installed where the plex user was disabled and permissions changed, it it would pay to check that. I did and there was no issue. If you do need to fix permissions your media folder should have the following permissions; Users group with read/write permissions

 

BTSync was a little more frustrating due to the fix for the problem. By default I disable the default admin account on all my devices, however with the current version of DSM and BTSync the default admin account (admin) MUST be enabled for it to run. This never was the case previously and BTSync guys said they MAY look into it but I have had to enable the admin account for now (and effectively reduce the security on my device, even if it does have a 32 random character password). Very frustrating.

Edited by ShadowPeo
Link to post
Share on other sites
itGeeks

Just thought I would post up this information (it is available at the respective sites/forums) I have just aggregated it here to help others.

 

Upon going to install the DSM 6 update over the past couple of days I ran into a couple of issues.

 

Trying to run the update with Plex or BTSync running gives errors stating they are not compatible, and depending on the version this is the case.

  • These versions I have confirmed to be working, both were downloaded on the 23/04/2016 and one would thing subsequent versions would also work.
  • These packages were downloaded from the publishers sites, NOT from the package centre as that is out of date
  • These are for AVOTON series processors I cannot confirm compatibility with other processors at this point (I will be able to confirm BTSync next week on a previous generation processor but those upgrades are not scheduled to happen until Tuesday/Wednesday)

 

Plex Media Server: 0.9.16.5.1966-81a3bf0

BTSync: 2.3.6-1

 

Run the updates BEFORE you upgrade DSM

 

The compatibility error ONLY occurs if the package is running, if it is stopped it does not occur so no need to uninstall completely

 

With Plex there was an issue with some releases prior to the one I installed where the plex user was disabled and permissions changed, it it would pay to check that. I did and there was no issue. If you do need to fix permissions your media folder should have the following permissions; Users group with read/write permissions

 

BTSync was a little more frustrating due to the fix for the problem. By default I disable the default admin account on all my devices, however with the current version of DSM and BTSync the default admin account (admin) MUST be enabled for it to run. This never was the case previously and BTSync guys said they MAY look into it but I have had to enable the admin account for now (and effectively reduce the security on my device, even if it does have a 32 random character password). Very frustrating.

Thanks for sharing all the great info on your upgrade experience. I also went threw some of the same pain you had though I don't use BTSync, There is no reason that it should only run under the default admin account and something they need to change ASAP. Like you I disable the default admin account and if a program insisted on using it I would be looking elsewhere for another program to use. For my media folder I have found it best to just allow the guest account so no user name password needed for that, That eliminates any possible problems with Plex and so on. Ya its not secure but its only the family media and I have it backed up onsite/offsite so I am not worried about it. One problem I had was I have/had two Synology 1815+ in a 'high availability cluster' and after the v6 upgrade it crashed my boxes, I had to do a factory reset to regain access to the boxes but all my data was still there. After I was able to log back in the boxes complained that they once belonged to a HA Cluster and I should remove the volumes and recreate them and of course that's what I did and everything seems to be working great now. What we can all take away from this and is best practice is ALWAYS update all the packages before any OS upgrade, That is stated by Synology.

Edited by itGeeks
Link to post
Share on other sites

I got the Plex error as well.  I disabled Plex, Installed DSM6 and all of its recent updates, then enabled Plex.  I can't remember if I did the package updates after or prior.  It all works fine though.  Right back to watching TV shows on Plex from my 1813+.  Works awesome.

Link to post
Share on other sites
itGeeks

I got the Plex error as well.  I disabled Plex, Installed DSM6 and all of its recent updates, then enabled Plex.  I can't remember if I did the package updates after or prior.  It all works fine though.  Right back to watching TV shows on Plex from my 1813+.  Works awesome.

Dave for Plex its best to go strait to the Plex website and download it from there, I have found that the Synology package center is not always up to date.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...