Jump to content
RESET Forums (homeservershow.com)

AHCI to b120i RAID, Server 2012 R2


ahenners
 Share

Recommended Posts

Hey, I'm wondering if anyone can help me with some issues i'm having in converting my existing Windows Server 2012 R2 installation from AHCI to RAID. It's on a 128GB SSD which was originally set up in AHCI, however I now want to use RAID via the b120i. Has anyone had any success going from AHCI to RAID with an existing installation?

 

I've tried installing the b120i RAID driver manually via cmd prompt using the pnputil command and the HPSA2.inf file, which shows it as having imported successfully. However, if I check the registry under CurrentControlSet\Services I do not see HPSA2 listed in there. Am I right in thinking that HPSA2 will need to show in there and have a Start value = 0 in order for my Windows installation to work with RAID on the b120i? Is pnputil the correct way to manually install a driver? I can't run the exe whilst in AHCI mode, otherwise it thinks it's not needed/compatible.

 

If I reboot, set the bios to RAID, create my Logical Disk and set bootable, it gets as far as the Windows logo but then Bluescreens with Inaccessible Boot Device error.

 

Any help would be appreciated as I've spent a fair bit of time today trying to figure this out and got nowhere! Reverted back to AHCI for the meantime and all is still working, but I'd like to have RAID 1 set up for the redundancy.

 

Thanks :)

Link to comment
Share on other sites

Moving from AHCI to a single drive RAID0 is easy, but as far as I know you cant go from AHCI to RAID1. The B120i does not support RAID migration. You would need to enable the B120i then make a RAID1 array with your two SSD's. Then install your OS.

Link to comment
Share on other sites

Moving from AHCI to a single drive RAID0 is easy, but as far as I know you cant go from AHCI to RAID1. The B120i does not support RAID migration. You would need to enable the B120i then make a RAID1 array with your two SSD's. Then install your OS.

 

Schoondoggy thanks for the quick reply! So basically I can't switch from AHCI to RAID 0 on the drive with the data already on, then add another Physical Disk into the Logical Disk and set it to RAID1?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...