Jump to content
RESET Forums (homeservershow.com)
Sign in to follow this  
Notbugged

WDRed constant clicking under Ubuntu Server ESXi

Recommended Posts

Notbugged

OK, so it seems, maybe ESXi does the disk running, will check on that and report back

Share this post


Link to post
Share on other sites
jmwills

OK, so it seems, maybe ESXi does the disk running, will check on that and report back

I did read in a blog about the Power Management difference between the HGST and the WD Red drives.  That is a Global Setting and cannot be individually implemented per drive.

Share this post


Link to post
Share on other sites
schoondoggy

If the drive is new, I would check in with WD support as well.

Share this post


Link to post
Share on other sites
ArnisR

It is some ESXi process - monitoring or something else. My Seagate Archive disks starts clicking every other second as soon as they are assigned to VM and VM is running (not mounted in VM, even in BIOS). If VM is down, they don't click. Nothing else except virtual disk images resides on these disks.

Share this post


Link to post
Share on other sites
Notbugged

I also thought ESXi monitoring, but does it also click in Your setup when the VM is powered down? In mine it does :/

Share this post


Link to post
Share on other sites
ArnisR

I also thought ESXi monitoring, but does it also click in Your setup when the VM is powered down? In mine it does :/

 If VM is down, they are quiet. ESXi is on SD card, ESXi logs and VMs itself are on separate SSD (in ODD, RAID0).  2xSeagates has RAID1 & RAID0 array for cold/archive data.

Share this post


Link to post
Share on other sites
Shonk

If you want to stop the head parking
It will make the drives live longer and stop the clicking

Seagates you have to have a script send a command on every boot
you will have to work out the drive locations in your hardware

smartctl -s apm,off /dev/sda
smartctl -s apm,off /dev/sdb
smartctl -s apm,off /dev/sdc

with the wd red early red's have the head parking seto to 8 seconds
later ones are set to 300 seconds

you can perm disable it with wdidle3 in dos or

http://idle3-tools.sourceforge.net/in linux


You may have to try -d sat if using the hp orom (not sure as i dont use it)

 

e.g.

 

smartctl -d sat -s apm,off /dev/sda

Share this post


Link to post
Share on other sites
Notbugged

Smartctl does not work (gives no data) when drives are configured as RAID0 single drive, not AHCI :/ Will try supplying drive as RDM, instead VMFS, will come back with information if that helped.

Share this post


Link to post
Share on other sites
Shonk

try

 

smartctl -d sat -i /dev/sda

Share this post


Link to post
Share on other sites
Notbugged

@Shonk: Read Device Identity failed: scsi error unsupported scsi opcode
 

I managed to finally solve the clicking. Backed up my data, reconnected drive to ESXi as RDM. Formatted in ext3 and retrieved the data. No clicking from now on :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×
×
  • Create New...