Jump to content
RESET Forums (homeservershow.com)

No SSD when B120i enabled?!


Gingerbeer
 Share

Recommended Posts

Hi guys,

 

I'm not sure if I'm being especially dense and missing something fundamental, but I'm stuck.  

 

I've removed all my HDDs and left the SSD on SATA5, and then I went into the smart array software and configured the SSD as a RAID0 array (single drive).

 

The Intelligent Provisioning software is of no use, so I can either install from bootable USB or my portable DVD drive, but neither one is of any use - I can get to the point in a windows installation where you can load SATA/RAID drivers but I keep getting a message that Windows cannot be installed on this drive (60GB Sandisk SSD).  This happens regardless of what RAID drivers I use.

 

I went into the BIOS and set the storage controller to AHCI SATA and I can install windows just fine, but what's the point of upgrading to a Gen8 if I can't use the RAID function?

 

Is there a way to make the Gen8 accept the SSD when the B120i controller is enabled?

 

[edit] Just slotted the HDDs back in and fired it up to be greeted by this message:

 

This is a NAS data disk and can not boot system. System halted.

 

I need a drink!

 

Any help on this would be bloody marvelous.

 

Regards

GB

Edited by Gingerbeer
Link to comment
Share on other sites

I was trying Windows 7 Pro.  I think the drivers for that are the Server 2008 R2 drivers.

 

When you say expand, do you mean extract them from the archive?  If so, yes.  If not, I'm not sure I understand.

 

It  lists two items the Smart Array and the B120i RAID controller, which I thought was the same thing, but selecting either of them still produces the same result:

 

On the drive selection screen, where you can delete volumes, load driver, etc.. it shows a little one line message underneath the options that says Windows cannot be installed on this disk.

 

I'll run through it again in ILO and get some screen grabs.

Link to comment
Share on other sites

The line at the bottom of this image seems to be the culprit, but the only way to resolve it is to disable the B120i controller

 

missing.jpg

 

Here's the error:

error.jpg

 

...and the expanded explanation, which kinda points back to the first image.  

 

error%20expanded.jpg

 

I have tried three different SSDs - a 60GB and two 256GB drives - and I've tried three different versions of windows, Win7 pro, Win7 Home Premium and Server 2012 Hyper-V. 

 

It reads like it MUST be a BIOS setting, but the only things I have fiddled with is the Storage controller selection i.e. AHCI SATA or B120i and the boot order.

 

It's a real head-scratcher.  I know running an SSD in SATA 5 is doable, but it feels like I'm missing an important step.

Link to comment
Share on other sites

You need to boot off Slot 1 on the B120i.

 

When I had mine, I used the following items to make it work:

 

SFF8087 to 4xSATA breakout cable

StarTech 4-port SFF8078 PCI-E card.

 

So, unplug the SFF8087 from the motherboard.  Plug that in to the StarTech controller.   Plug your breakout cable in to the motherboard and plug the SSD in to the "1" cable on there.  All should work fine now.

Edited by HellDiverUK
  • Like 1
Link to comment
Share on other sites

I finally worked it out and it turns out I was right all along - I was being especially dense.

 

In the smart array config (F5 option at POST), I had to select the volume that related to the SSD as bootable.  The last time I played with that, I was transferring the XPEnology drivers from my Gen7.  Since XPEnology installs a copy of itself to every drive in the array, I used a drive I had slotted into Bay4, but it wouldn't boot until I point the array controller at it.

 

The odd thing is that I've made so many changes to the Gen8 since then, clearing the array, changing/wiping/reconfiguring drives etc.. it never occurred to me that it would still try to boot off the drive I had in bay 4; and when that drive was removed, it default to zero drives eligible for boot.

 

Two days of head scratching all because I assumed that setting would revert to default.   :rolleyes:

 

Oh well, maybe my documented stupidity will help someone else one day.

 

Regardless of the above, thank you for taking the time to reply, guys!   :)

Edited by Gingerbeer
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...