xPETEZx

Full Restore via PXE

20 posts in this topic

Hey Guys,

 

Browsed this forum a fair few times, helped me on various issues with Server 2012R2 Essentials.

 

Have my first question. 

 

I run 2 WSE2012R2 servers with the Essentials role added. Both I have setup with various client computers and all are setup for full backups. Mix of Win 8.1 Pro and Win 10 Pro clients.

The backups run great. As does doing the restores of files. No issues.

 

To be prepared I wanted to test the Full System restore using PXE boot. I installed the service on the server. Then PXE booted a Gen2 VM. (To try a UEFI restore)

The machine PXE booted fine and I managed to get all the way to the disk Partition section.

I tried this with a Gen2 VM about 4-5 times, and I would say 3 of the times I was prompted to format the disk myself. The other 2 it auto-formated the disk as it was before.

When I had to manually format the disk, I tried just creating it myself using the GUI or using Diskparted as instructed here: https://technet.microsoft.com/en-us/library/jj713539.aspx

 

Out of the 4-5 restores I did to a VM, only 1 of them was able to boot straight out the box. Nothing needed. 

One of of them I needed to boot into Windows Setup, run Diskpart set a drive letter to the C volume then run bootrec /scanos bootrec /rebuildbcd and bootrec /fixboot to get the machine to work.

 

The other 3 times I could not get the VM to boot at all. Got messages about winload.exe being missing or 0xc00000e error saying I needed to repair the install. (Which didnt work)

 

I also tried a restore on a Gen1 VM, but this failed as the machine I was restoring did have UEFI bios, so made sense it failed.

 

Lastly, I also tried a physical PC restore. Windows 10, but no UEFI bios.

The restore completed, but again the machine failed to boot with the 0xc00000e error. 

 

I have only been test restoring. So my machines are all good. Its really just to know it will work if I ever needed it in anger. 

Glad I tried. Because what seems so simple on the surface is turing out to be far more difficult than expected.

 

Can anybody give some pointers with the PXE boot full system restore?

 

I think my problems all arise around the partition creation.

As I said I have had the wizard offer me to create the volumes, I have created them with the GUI and I have created them with Diskpart.

Each time I made sure only to continue if I do NOT get the prompt saying something to the effect of "This restore includes a boot volume, this is not being restored or set to boot" (Cant remember exact phrasing)

 

Any help appreciated!

 

Share this post


Link to post
Share on other sites

Do "bootrec /fixboot" first, then "bootrec /rebuildbcd". IT should be in that order specifically, and you shouldn't need all of the commands.

 

If that doesn't work, run a Windows Install. Reboot it wwhen it starts copying files over (or wait), then you can restore.

Share this post


Link to post
Share on other sites

Are the volumes getting created?  I ran through all these command last weekend when rebuilding a Surface Pro 3 that had BitLocker on it.  Some of the devices don't like to PXE boot unless the boot partition is already there and has to be as large as it was previously.  Only way to do this is through DiskPart.

Share this post


Link to post
Share on other sites

Yes the volumes create. When I attach the vhd or physical disk to another system, everything looks to be there.

All but the one time I managed to fix the system by using bootrec /rebuildbcd the command found no OS.

 

So you guys recon start a windows install on the blank disk to get the right partitions, the restore over it?

 

Any of you used it in anger?

 

As said, I did try with both diskparted and the GUI tool.

Only successfully one time.

Share this post


Link to post
Share on other sites

I would manually create the partitions needed.  There are some old threads on here about this.

Share this post


Link to post
Share on other sites

I would manually create the partitions needed.  There are some old threads on here about this.

I did on some of my tries.

 

I used the link at the top from MS as a guide.

 

This worked once, but the rest of the times I either had to then do rebuildbcd or failed to get the machine to boot.

 

Its a slight shame. I am sure if I do ever need to use this in anger, ill get it to work. At that point Ill have no choice.

 

Was hoping to set this up for family and give them simple instructions to use it. But all this disk formatting, BCD rebuilding etc is not for them.

Share this post


Link to post
Share on other sites

Have you looked at the free Veeam backup product?  It works pretty good.  Just create a shared folder on the server to point the backups to, install the product (very lightweight) and create the boot media.

Share this post


Link to post
Share on other sites

Unless I am missing a version, it looks like there is no free version of this.

 

Not keen to spend more money on a solution I already have. Ill stick to using the one built in to WSE2012R2. 

 

Going to try the USB Key method for my family. See if that works more reliably.

 

If that too is problematic, ill just have to have work through the issues, or clean install windows then use the connector to restore data. (Or is it possible to restore the OS with the connector too? Think its just files)

Share this post


Link to post
Share on other sites

I must have had a search fail. Could not find that when I googled.

 

Is this what you use in place of the WSE backups? Or run both?

 

Looks promising. Will give it a shot! Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now