Jump to content
RESET Forums (homeservershow.com)

WSE12R2 Dashboard.exe crashing


Recommended Posts

So I have a really simple question.... how do I remove .NET 4.6 ? 

I had 4.5.2 installed, but for some reason my Remote Web Access site did not work.

I tried to repair 4.5.2 but that did not seem to resolve the issue.

 

I upgraded to 4.6 and Remote Site works. However dashboard crashes as per this topic.

 

I managed to remove the 4.6.1 update, but cant seem to remote 4.6 and go back to 4.5.2 (and hope that somehow remote web access still works!)

 

The odd thing is, I run 2x 2012R2 WSE servers. One of them updated to 4.6.1 automatically, and works perfectly. Dashboard has been open for days without issue.

My other, has the topic problem.

 

Help appreciated. :)

Link to post
Share on other sites
  • 4 months later...
  • Replies 36
  • Created
  • Last Reply

Top Posters In This Topic

  • Jason

    19

  • Drashna Jaelre

    8

  • xPETEZx

    4

  • oceang

    3

I've since tried to roll back to NET 4.5.2 without success.  Now even then, my WSE12R2 dashboard crashes.  So I updated from 4.6 to 4.6.2 and the dashboard crashing persists with a kernelbase.dll fault.  Seems commonly reported online but no MS resolution that I can find.  Isn't attributed to any one WSE12R2 add-in in particular.

Link to post
Share on other sites

Turns out my Dashboard.log file shows a consistent !!!!FATAL error right before it closes. Not a sign of a MS resolution anywhere. Disabling add-ins has no impact. Of course the Dashboard staying open isn't mission critical as my WSE12R2 still operable. But an annoyance not knowing the root cause.

 

 

Sent from my iPhone using Tapatalk

Link to post
Share on other sites

Drashna, just tried disabling all standard MS dashboard add-ins...leaving my Cloudberry, iHomeserver, Stablebit Scanner and Drivepool add-ins running.

 

Seems the Dashboard did not crash.

 

So I'm gradually enabling one standard MS add-in at a time to see if I can isolate the offending one (users, user groups, server folders, group policy, health report, etc).

 

Once it fails, I'll provide the Dashboard.log and info on the first add-in that caused the crash.

 

 

Sent from my iPhone using Tapatalk

Link to post
Share on other sites

So I've uninstalled every Windows Update (KB) on my WSE12R2 box that had been installed since 3/1/16 and reinstalled .NET Framework 4.5.2 and my Dashboard appears to be behaving as expected.  Staying open.  Not closing.  Now these are the "Important" updates that the server is prompting me to install.  Before I start applying them one at a time, are there any that are absolutely critical?

 

KB2934520 - NET Framework 4.5.2 update

KB2922229 - Security Update for Windows Server 2012 R2

KB2961899 - Security Update for Windows Server 2012 R2 (without KB2919355)

KB2962123 - Security Update for Windows Server 2012 R2 (without KB2919355)

KB3172729 - Security Update for Windows Server 2012 R2

KB2939087 - Update for Windows Server 2012 R2

KB2919355 - Windows Server 2012 R2 Update (693 MB)

 

It appears Plex Media Server won't even run without this KB2919355 update.

Edited by Jason
Link to post
Share on other sites
  • 4 weeks later...

Are you also receiving? Unfortunately what I ended up doing was painful but successful. I was trying to avoid a clean OS install.

 

- uninstalled all windows updates from server

- reinstalled NET Framework 4.5.2

- confirmed Dashboard no longer crashed

- setup WSUS to receive only security and critical updates

- approved WS2012R2 updates month by month and installed them, checking to ensure Dashboard didn't crash

 

I'm certain a WIndows Update (KB) caused the issue but I'm now current on updates and server working fine.

 

 

Sent from my iPhone using Tapatalk

Link to post
Share on other sites
  • 2 weeks later...
Drashna Jaelre

 

 

Nope. Andy doesn't know what he's talking about, and speaking out his ass, out of anger. 

 

https://support.microsoft.com/en-us/lifecycle/search/16526

 

Mainstream support for Server 2012 Essentials doesn't end until next year.  Extended support (security updates) doesn't end until 2023. 

 

And the same goes for Server 2012 R2 Essentials, as well. 

 

https://support.microsoft.com/en-us/lifecycle/search/17383

 

 

But the problem here is several:

This is an issue with .NET Framework 4.6.1+ explicitly.  

Since the dashboard is written in .NET... then this can/will cause issues.  Especially if certain add-ins are calling methods that are not supported.

 

Andy's issue appears to be a rending one, with one of the add-ins present, but he hasn't actually pinpointed what the issue is....

 

 

Also, the Server Essentials Experience is a niche role/feature, so it doesn't get as high priority.  Compounded by the fact that nobody really has opened an official ticket (since Microsoft shut down Connect, this requires money to do so).

 

 

Either way, it's a shitty situation, and the best "solution" is to upgrade to 2016, as it shouldn't experience this issue. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...