Jump to content
RESET Forums (homeservershow.com)

Slow SSD Write Speed B140i ML30 G9


Joe_Miner
 Share

Recommended Posts

I have two Samsung 840 Pro 256GB SSD's attached to ports 5 & 6 (SATA III's) off the System Board -- I set them up in a RAID0 on the B140i and am getting the following performance (the Read speed is good but Writes are awful):

 

Capture18_20160217Performance_zpsq9rpxsr

 

 

Whereas on the ML10v2 with B120i on Ports 1 & 2 (SATA III's) I had good Writes as well as Read speeds

02-20151215_DriveC.jpg

 

I'm sure I'm doing something wrong to mess up the Writes but don't know what?

Edited by Joe_Miner
Link to comment
Share on other sites

Assume these are in the Icy Dock MB994SP-4SB-1 (as per your other post), have you tried them out of it. Also, what about trying just 1 disk on it's own.

  • Like 1
Link to comment
Share on other sites

Assume these are in the Icy Dock MB994SP-4SB-1 (as per your other post), have you tried them out of it. Also, what about trying just 1 disk on it's own.

 

They had been hanging free before I moved them to the MB994SP-4SB-1 -- I think my next step would be to go back to the original hanging free and run the tests again.  I think you're right that after that I may need to test the SSDs one at a time.

 

I thought I could get some things done using ports 5&6 while waiting for my LFF drive caddys to arrive for the main 4 drive bay.

Is write caching enabled? Is it the same as the B120i, i.e. no battery back up available or anything like that?

 

Pretty much the same as with the B120i in the ML10v2 AFAIK except the ports are SATA III

Link to comment
Share on other sites

I pulled both SSDs out of the MB994SP-4SB-1 and attached them directly to Ports 5 & 6 and got essentially the same sad performance as above

 

My hot-swap caddies came in the mail today -- that I had ordered from eBay -- so using an icy Dock EZConvert I installed two other Samsung 840 Pro SSDs in slots 1 & 2 (Bays 1&2) of the ML30G9.  I set each as a single drive RAID0 and ran CDM on them:

 

 

 

WP_20160218_15_04_11_Pro_zpsrfjocr42.jpg[/uR

 

WP_20160218_14_44_19_Pro_zpsh0x3l7ya.jpgL]

 

 

I think I'll move one SSD to my Gen8 and see what happens

Edited by Joe_Miner
Link to comment
Share on other sites

Is write caching enabled? Is it the same as the B120i, i.e. no battery back up available or anything like that?

Have you checked the cache settings in SSA? I think write cache is turned off by default.

Link to comment
Share on other sites

The B140i doesn't have a battery so write cach is 0 just like the B120i

 

The same Samsung on Port 2 of the ML30 G9 (B140i) gave a performance of:

 

WP_20160218_15_04_11_Pro_zpsrfjocr42.jpg

 

I moved it to the G8 MS Port 2 and got (B120i):

 

WP_20160218_16_56_59_Pro_zpsir7gxiyc.jpg

 

So apparently I'm missing something on the B140i (BTW -- don't know if it's related but it's throwing me an error saying the SSDs on Ports 1&2 (no error message on the Samsungs on Ports 5&6) is not HPE and it will not display indicator lights

Link to comment
Share on other sites

Hat tip to Schoondoggy for pointing me to this User Guide http://www.hp.com/ctg/Manual/c03909334

 

I had been looking at a different User guide

 

Page 44 has info on Enabling the Physical Drive Write Cache State which has helped my write speeds (~490 Sequential Write & ~513 Sequential Reads on a single drive RAID0 SSD but my duoDrive RAID0 SSD pair is stil below 190 Sequential Writes & ~950 Sequential Reads  Capture21_Page44UserGuide_zpsmw5kiw5q.jp

 

Capture22_zpsheuzrcoc.jpg

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • denniswier
      By denniswier
      Casus:
       
      Hoping that the HDD PCB can be exchanged with an PCB of the G9/G10 series.
       
      I know it has to be 4x 3.5"
      But it has to fit by screws.
       
      The connectors are: 4x sata-like connector with Power molded like an SAS connector.
       
      The info that i could find on the cage is:
       
      PartNo: 90.5P620.001G

    • Rodf
      By Rodf
      I'm looking into replacing my desktop's old, failing HD with an SSD. I've got a Dell XPS 8700. I've look up the configuration on Dell's website, entering my machine's service tag (DK49122). I've found the component which is listed as:
       
      KPF74 : Module,Hard Drive,1T,S3,7.2K,5 12E,#1,G-BP INFO,1ST BOOT,HARD DRIVE HD,1TB,S3,7.2K,512E,SGT-GRDABP  
      I know it's a 1 TB drive. It looks to me like it's a SATA III drive. Am I correct? 
       
      Assuming I've correctly identified the drive, then I've found what looks like a good replacement part on Newegg which is listed like this: SAMSUNG 860 EVO Series 2.5" 1TB SATA III V-NAND 3-bit MLC Internal Solid State Drive (SSD) MZ-76E1T0B/AM
       
      So, have a got a good replacement SSD for my machine's old HD?
    • xelent
      By xelent
      Hi there,
       
      I've just gotten my old Proliant server out from mothballs recently to use as a Backup controller for my photographic archive. It's specs are a standard G840 2.8GHz Dual core with 16 GB of ram installed with a standard 350 watt PSU. I'm running WSE 2019 with 4x1TB HDD's installed in the 4 bay drive cage. 3 drives are formatted to RAID 0 in WSE (not embedded HP RAID) and one drive acts as the system/boot drive.

      The server is surprisingly responsive given its age, with LAN transfer speeds between 84-94MBs. So has pretty much taken center stage in my backup control between my  external drives and 4x1TB RAID 0 NAS.
       
      However, I have been wanting to attach a 256GB SSD boot drive for my OS, so that I can utilize the full capacity of my 4 bay drive. It seems that the BIOS will not let you boot any HDD/SSD off the spare SATA connection on my MB. Anyway I am hoping to eventually attach a PCIe USB 3 card to that. But in the meantime I would like to boot a separate drive other than the 4 bay one already installed.

      I gather that you can install a PCIe SSD card on this machine. But it's not clear to me as to what kind of card and drive would be suitable for this server. I realize that my MB is PCIe gen 2, which will incur diminished speed compared to the latest gen 3 MBs. But should I be using NVMe or SATA m.2 drives? Or does it even matter? Also will the BIOS allow me to boot from this drive?
       
      Thanks for taking the time.
    • Karazzi
      By Karazzi
      Hi everyone.
       
      New to this forum.
      I have a gen8 microserver running at home, where I have installed an SSD in the ODD sata slot. On the SSD I have installed Ubuntu Server 18.04.
      I have then created a logical volume witht the raid controller and can then boot to the SSD. So far so good.
      My problem emerges when I reboot the system. The logical volume disapears and it gives the error: "boot logical drive is configured but is missing or offline".
      I then have to go into the utility and reconfigure the logical volume. Kind of annoying, when trying to run a headless setup.
       
    • Warren89
      By Warren89
      Hello all, i am very new to all of this, i have a ml10 gen 9 with unraid on at the moment but i have used all 4 bays that come with it, can someone help or show me what i need or could doto be able to put more HDD in the system.
       
      At the moment i have one for parity, one for cache and two for storage.
       
      Hope someone can help.
×
×
  • Create New...