Jump to content
RESET Forums (homeservershow.com)
artiom

Cisco SG300-10SFP + Multi-port NICs issue

Recommended Posts

artiom

Hello to everyone,

 

I got a strange problem with a switch in the following environment:

Switch: Cisco SG300-10SFP

Servers:

1. Dell PowerEdge T710 with 4-port Broadcom NIC (+1 iDRAC Enterprise port on a separate NIC).

2. HP Microserver G8 with a 2-port NIC (+1 dedicated iLO port).

 

Problem:

The switch restarts by itself when I connect more than one port of the same NIC, the more ports I connect - the more often it restarts.

For example, if I connect both ports of HP MS G8 - it restarts approx once in two hours, but if I connect all ports of both servers - it restarts continuously and it is pretty unusable.

If I connect all dedicated management ports of both servers and just one nic port of each server - it is rock stable and works perfectly.

 

The Cisco log does not contain any relevant information. The switch is updated with the latest firmware atm, QoS is disabled and no other specific configurations were made.

I just need it to work as a dumb switch with all ports connected.

 

Does anyone have any ideas where to dig to fix this problem? Maybe someone already encountered such behavior on Cisco SG300 series?

 

Thank you for reading!

Share this post


Link to post
Share on other sites
GotNoTime

Does anyone have any ideas where to dig to fix this problem? Maybe someone already encountered such behavior on Cisco SG300 series?

Try disabling SmartPort.

Share this post


Link to post
Share on other sites
artiom

Hm... the smartport functionality looks disabled, but the "discovery" is enabled - will try to disable and reconnect all cabling this evening. Thank you for suggestion.

Share this post


Link to post
Share on other sites
psykix

Check if port security is off.. that used to cause me no end of problems on the bigger switches I used to manage - kept shutting down the ports on me..

Share this post


Link to post
Share on other sites
artiom

I just tried all sugestions, then I did a factory reset, then reconfigured it back, tried to disable all uneeded services again, etc. And nothing helps :(

Looks like I need another switch... does anyone have a spare 10+ port switch in Bristol, UK? :)

Share this post


Link to post
Share on other sites
GotNoTime

I just tried all sugestions, then I did a factory reset, then reconfigured it back, tried to disable all uneeded services again, etc. And nothing helps :(

Yeah. It sounds like it is faulty unfortunately. Can you get it replaced under warranty? Cisco offer a limited lifetime hardware warranty on that switch.

Share this post


Link to post
Share on other sites
artiom

Unfortunately, I do not think I can replace it under warranty - I friend of mine just gave it to me as is ~a year ago. It works perfectly unless I connect two or more ports of the same NIC.

I ordered another switch (HP ProCurve 2510G-24) and will test with that one - if it will have the same glitches - then it's something to do with Windows Server 2012 default network configuration.

 

Thank you for suggestions anyway - the community here is always helpful.

Share this post


Link to post
Share on other sites
LoneWolf

Cisco SG300 switches generally have a lifetime warranty.

 

I have my HP Microserver Gen8 connected to my SG300-10MPP on two ports in a LAGG with LACP on, and have never had an issue.  I think you have a faulty switch, or you need to upgrade the Broadcom NIC firmware.  I would normally test with an Intel dual-port NIC at this point; I have had quirky issues with Broadcom NICs in some situations that I don't have with Intel.

 

What operating systems are you using on the systems, and how do you have the link aggregation set up?  Note, I'm not using Broadcom's software; Server 2012 and 2012 R2 have eliminated my need to do so, and I prefer to avoid Broadcom's BACS when possible.  I actually had it break a Windows 2008R2 network stack once; the issues have been bigger for me on Dell servers than others, and I actually had them on the T710.  There are a number of documented complaints about Broadcom on multiple generations of Dell servers up through the x10.

 

One recommendation: In addition to making sure you have the latest Broadcom firmware and drivers for your NICs, disable TCP Chimney offload if you have issues.  There are plenty of times Broadcom server NICs have an issue with this enabled.

Share this post


Link to post
Share on other sites
artiom

Thank you for suggestions, but currently I can't test them because I replaced the Cisco switch with the one mentioned in previous post (HP 2510G-24) - it is more than enough for my needs and all works perfectly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • JROrtiz
      By JROrtiz
      I've been banging my head for a few days now trying to figure this out and I've run out of ideas. Hoping the very intelligent crew here can help me out.
       
      I have a Drobo 5N and a Synology RS816 on my network, both of which have been working without issue for quite some time now. I've always connected to both via Windows Explorer by simply going to the network address i.e., \\N5 and \\SYN (sample names). 
       
      I recently got a new desktop which is where the issues are coming up. When I try to go to \\N5, it results in a message saying it cannot find that location. However, \\SYN works just fine. What's strange is that I can see and manage the Drobo through the Drobo Dashboard software. What could be preventing Windows from seeing the Drobo on the network? 
       
      I've already enabled the SMB 1.x protocol, ensured the workgroup names are the same, rebooted both the machine and the Drobo, made sure network sharing is enabled, and even did a fresh install to ensure that some program I installed didn't cause the issue. Every other machine I have can access the Drobo without issue. It's just this new desktop, and everything is running Windows 10.
       
      Another strange phenomenon that I discovered is that if I go to "\\DROBO" (verbatim, not a sample name) it leads me to the Synology. Where is Windows getting the mapping from that it is directing that address to the Synology?
       
      This is driving me nuts so any advice would be greatly appreciated.
    • Jason
      By Jason
      Have been running a Windows DHCP server on home WSE12R2 box for quite some time behind my Sophos UTM firewall. Also allowed me to seamlessly run Windows Deployment Services at home. WDS just worked.
       
      But if I needed to make a particular LAN IP address exception on the firewall, I had to 1.) create a Windows DHCP server reservations AND 2.) create a network definition for that IP on the Sophos UTM box. 2 steps. Not very efficient; was sure I was doing something incorrectly...
       
      Tried to migrate to Sophos UTM running the DHCP Server, but now WDS doesn't work. LAN devices can no longer PXE boot. Seems possible. Many guides. None have proven especially successful.
       
      Is it possible to run a Windows DHCP server and have Sophos UTM import DHCP reservations instead of maintaining 2 unique entries for each IP reservation (one in Windows DHCP, another on Sophos UTM box)?
       
      What is best practice?
       
       
      Sent from my iPhone using Tapatalk
    • donschmidt
      By donschmidt
      Good morning.  I've just  purchased a home still under construction and plan to have CAT6 installed throughout the living areas. I'm hoping that someone can advise me as to the specific quality/specs of cable that I should use.
      Thanks and Happy New Year.
    • Joe_Miner
      By Joe_Miner
      I've been looking at the Intel Compute Stick BOXSTK1AW32SC and was wondering if anyone here has experience with that and if the Intel AC 7265 built into it is backwardly compatible with older N and A,B wifi?
    • heavy21
      By heavy21
      I want to optimize the performance and security of my home network of servers, PCs, laptops printers, smartphones, TVs, etc.  Current network appliances include layer 2 and 3 switches (Cisco small business) and Linksys router.  I’m looking to replace the Linksys with a security (pfSense) router appliance (w/OpenVPN).  I will also be adding security cameras and a NVR to the network.
       
      The gigabit network is straightforward in structure with all Ethernet connections hanging off the24 port switch connected to the cable modem and router except a cascaded 8 port switch in a room to provide 4 Ethernet connections in a room with only one data port.  Wireless connections presently come off the Linksys but will eventually come off the to-be-purchased security/router appliance with a wireless card.  I don’t see more than 100 devices in total for the whole network.  No VLANS and no sub-netting.  All hardware supports IPv6.
       
      Hardware line up is:
      Dual Zeon server w/RAID 10 of 24 TB of storage, 64GB memory
      Cisco managed switches layer 2 and 3
      HPEX495 server
      Workstations, Desktops, Laptops, Tablets, iPads
      Printers
       
      Software line up is:
      Windows Server Essentials 2012 R2, single domain controller, storage and file server duties
      Windows 10 Pro all non-server Intel computing devices
      PLEX server for streaming audio and video to display units
      Office 365
       
      From what I’ve read so far, it appears that I need to incorporate an IP addressing scheme for clients and servers on the network.  It would also appear that I need to implement VLANS and/or sub-netting to protect access to certain files and security footage, provide guest networking with future consideration for electronic door locks and some sort of server based media distribution to various display devices,
      What are best practices on assigning client and server devices to IP ranges, fixed or dynamic IP addresses?  Do I need to assign clients or servers to IP ranges?  What are the considerations in establishing sub-nets over VLANS or vice versa?  I’m pretty sure I want to restrict access to cameras and their security footage and personal files on my workstation.
       
      Thanks for any resources and advice provided.
       


×
×
  • Create New...