Jump to content
RESET Forums (homeservershow.com)

Unable To Uninstall CrashPlan and Errors From Update


Recommended Posts

vwsplitty1980

Good Morning,

 

I am not quite sure if this is the correct section but as the title says i am having problems with my normally solid setup of crashplan. I have emailed the CS of Crashplan but i would also like to run the below past any all the pepole of here also. Below is what i sent to CS:

 

I have had crashplan working for sometime now and it always updates without a problem. But on it trying to self update to 4.5.2 it just fails and then the app crashes. I have a yearly subscription and would like some help with this.

i run windows server 2012 r2 fully up dated and the installed version showing in my add/remove programs is crahplan 4.3.0, i read on your site that clearing the cache of crachplan often solves such problems. i did clear the cache but it would still get the same update error. Now this is where is gets very strange as you surggest the next thing to do is uninstall the old version and reinstall the new version.

on trying to uninstall the old version server 2012 r2 tells me that as admin i do not have sufficient privileges to do so!. I have checked in the admin option and the local security policy's for software are NOT set. I did try enabling this and selecting admin as not being affected by this policy but i still get the same error. I have tried to remove other programs on my sever 2012 r2 and they all remove just fine. So this bring me to yourself as i am guessing that something is corrupt within crashplan?.

p.s i did try just installing the  new version hoping this would self uninstall the old version but alas i ended up with both versions on my server and i could still only uninstall the new version.

any ideas at all?

 

So as i see it i have two problems that may very well be the same problem. Crashplan fails on its update plus i can not seem to uninstall it?

 

Cheers in advance. :D

Link to post
Share on other sites

Good Morning,

 

I am not quite sure if this is the correct section but as the title says i am having problems with my normally solid setup of crashplan. I have emailed the CS of Crashplan but i would also like to run the below past any all the pepole of here also. Below is what i sent to CS:

 

I have had crashplan working for sometime now and it always updates without a problem. But on it trying to self update to 4.5.2 it just fails and then the app crashes. I have a yearly subscription and would like some help with this.

i run windows server 2012 r2 fully up dated and the installed version showing in my add/remove programs is crahplan 4.3.0, i read on your site that clearing the cache of crachplan often solves such problems. i did clear the cache but it would still get the same update error. Now this is where is gets very strange as you surggest the next thing to do is uninstall the old version and reinstall the new version.

on trying to uninstall the old version server 2012 r2 tells me that as admin i do not have sufficient privileges to do so!. I have checked in the admin option and the local security policy's for software are NOT set. I did try enabling this and selecting admin as not being affected by this policy but i still get the same error. I have tried to remove other programs on my sever 2012 r2 and they all remove just fine. So this bring me to yourself as i am guessing that something is corrupt within crashplan?.

p.s i did try just installing the  new version hoping this would self uninstall the old version but alas i ended up with both versions on my server and i could still only uninstall the new version.

any ideas at all?

 

So as i see it i have two problems that may very well be the same problem. Crashplan fails on its update plus i can not seem to uninstall it?

 

Cheers in advance. :D

I would try and remove it in safe mode and see what happins http://www.isunshare.com/windows-2012/boot-windows-server-2012-in-safe-mode.html

I would also try logging to to windows server with a local admin account and try to uninstall Crashplan. You could also try a program like Revo but in your case because it seems to be a permissions issue I don't think Revo will help http://www.revouninstaller.com/revo_uninstaller_free_download.html

 

Summing it up boot into safe mode login with a local admin account and try to uninstall Crashplan. You may also want to try the repair options if the add/remove programs give you that option. Also try and reinstall the same version if you still have that. Hope some of this helps.

Edited by itGeeks
Link to post
Share on other sites
vwsplitty1980

I would try and remove it in safe mode and see what happins http://www.isunshare.com/windows-2012/boot-windows-server-2012-in-safe-mode.html

I would also try logging to to windows server with a local admin account and try to uninstall Crashplan. You could also try a program like Revo but in your case because it seems to be a permissions issue I don't think Revo will help http://www.revouninstaller.com/revo_uninstaller_free_download.html

 

Summing it up boot into safe mode login with a local admin account and try to uninstall Crashplan. You may also want to try the repair options if the add/remove programs give you that option. Also try and reinstall the same version if you still have that. Hope some of this helps.

 

Hi i did try booting to safe mode but i kept getting a message about the uninstaller service not working. After a bit of digging and following the below guide i had to add to this key location "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal\" the

new key "MSIServer" and select the default value as "service". It must be due to the crashplan installing using a .MSI? never the less after doing that i was able to uninstall straight away and then reboot to normal mode. Have just put on the new version of crashplan and im just watching it doing its thing. ill post back when up and fully running.

 

https://www.raymond.cc/blog/uninstall-programs-packaged-with-windows-installer-in-safe-mode/

Link to post
Share on other sites

You could do a Server restore to a time before all this happened and turn off auto update on that App.

Link to post
Share on other sites

Hi i did try booting to safe mode but i kept getting a message about the uninstaller service not working. After a bit of digging and following the below guide i had to add to this key location "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal\" the

new key "MSIServer" and select the default value as "service". It must be due to the crashplan installing using a .MSI? never the less after doing that i was able to uninstall straight away and then reboot to normal mode. Have just put on the new version of crashplan and im just watching it doing its thing. ill post back when up and fully running.

 

https://www.raymond.cc/blog/uninstall-programs-packaged-with-windows-installer-in-safe-mode/

I am glad your making headway :)

Link to post
Share on other sites
vwsplitty1980

Update: everything seemed ok but I always had the crashplan tray app greyed out and could not get any incoming connections. I used revo uninstaller and removed everything crashplan I could find. Re installed v 4.5.2 crashplan and once again all is green and seems ok, just waiting again to re sync to crashplan cloud/home and fingers crossed

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...