Jump to content
RESET Forums (homeservershow.com)

Help! HP Proliant Microserver G8 g1610T - Cannot install Windows


lsqbfljb
 Share

Recommended Posts

Been lurking here for a while. Got two Gen8, with extra SDD, 16GB RAM, 4x1TB WD RED, 1230v2.

First one installed like a charm, as a ESXi host.

 

Second one, I've been trying to install Windows 7/8/10 and still no luck.

 

First of all, I'm on a MacBook Pro with Windows 7 running on Parallels Desktop.
But that shouldn't be much of an issue, been using it for years and provisioning machines no problem. 

That second Gen8 is using stock celeron, haven't upgraded yet.

 

Issues I ran into were numerous.

 

Loading off USB (USB2 ports front and back) and loading driver off ILO folder (Win2008R2 for windows 7 and Win2012R2 for Win10 ) 

but had issues where "Setup was unable to create a new system partition or locate an existing system partition" 

Tried disk part, reformat, erase, change boot order in BIOS (USB after SSD), reset drives array & select boot drive in smart manager. Nothing. 

 

Burned a DVD, mounted off ILO, and it suddenly shut, saying ILO was not supported for this after POST, though I did get 2 ILO licences trials for both machines. Upon re-entering licence it just said "meh, this one's been used already" 

 

Tried "Intelligent" provisioning, tried USB, it saw it, saw the .iso, double clicked it, nothing. 

Tried "Intelligent" provisioning, tried Network Share, it opened it, saw the .iso, double clicked it, nothing. 
Tried "Intelligent" provisioning, tried DVD, saw it, saw the .iso, double clicked it, nothing. 

I just spent the last two week ends trying to get this damn thing to work. 

Oh and when all worked, (USB/DVD/SSD etc) "windows cannot install required files error 0x8007025d" 

I'm going to throw in out the window. 

 

At this stage, I am thinking of removing SSD, putting it into a caddy I have, on to an USB external HDD reader, install on external SSD this way and put it back in the Gen8? That would work? 

 

Edited by lsqbfljb
Link to comment
Share on other sites

What port is the SSD currently on?

Are you running AHCI or the B120i?

If you are using the B120i, do you have the driver available for it?

Link to comment
Share on other sites

What port is the SSD currently on?

5th, ODD Port

Are you running AHCI or the B120i?

Not sure. B120i I think. (see below) How/why would I want that changed? This is the one thing I'm still having issues with. 

If you are using the B120i, do you have the driver available for it?

Yes. Loaded them off ILO folder and it was able to see the drives once it had loaded it. (RAID drivers off HP Site) 

 

Edited by lsqbfljb
Link to comment
Share on other sites

Here is a thread working through Windows install:

http://homeservershow.com/forums/index.php?/topic/10550-raid-on-windows-81-hp-gen8/

 

Ok, got a quick overview of AHCI, 

http://homeservershow.com/installing-whs2011-hp-proliant-gen8-microserver-ahci-enabled.html 

 

It could be that I need a smaller logical drive created on the SSD, will try it.

2TB is the limit for boot drives, I dont think your SSD volume is bigger than that.

 

Have you watched this video:

https://youtu.be/fZoxCqetIhw

Link to comment
Share on other sites

 

Tried disk part, reformat, erase, change boot order in BIOS (USB after SSD), reset drives array & select boot drive in smart manager. Nothing. 

 

How are your drives configured in SSA? Can you post a screen shot?

Link to comment
Share on other sites

I recall someone else having issues in the past when trying to make a Windows bootable USB on a Mac -- I don't recall what they did to resolve it but it may be worth checking the past threads on Windows installation

 

If you're going to attach your OS drive to the ODD SATA port by far the easiest installation is to make that a RAID0 drive in the SSA

 

Make sure you have the latest Firmware by running the SPP (latest version is 2015.10.0 ) 

 

2015.10.0 FTP http://homeservershow.com/forums/index.php?/topic/10425-new-hp-proliant-firmware-iso-12-2015/?p=109659

 

also check out:

HP ProLiant MicroServer Gen8 Drivers and Software http://h20566.www2.hpe.com/hpsc/swd/public/readIndex?sp4ts.oid=7298965〈=en&cc=us

MicroSoft Windows Server 2008R2 Downloads http://h20566.www2.hpe.com/hpsc/swd/public/readIndex?sp4ts.oid=7298965&swLangOid=8&swEnvOid=4064

MicroSoft Windows Server 2012R2 Downloads http://h20566.www2.hpe.com/hpsc/swd/public/readIndex?sp4ts.oid=7298965&swLangOid=8&swEnvOid=4168

For Entitlement Required Downloads (such as for SPP) you’ll need to create a Passport account with HPe and associated the Server Serial Number with that Passport account to get the Entitlement Required Download (if within the warranty period)

 

Check out the Windows installations in CSKenney’s ProLiant MicroServer Gen8 Links http://homeservershow.com/forums/index.php?/topic/5639-proliant-microserver-gen8-links/

 

The 320e and the ML10v2 have the B120i and the procedure for Windows is virtually identical to the G8 MS

 

IP on the 320e and G8MS only will work with the install of a HP Supported Server OS -- not a Desktop Windows

Edited by Joe_Miner
Link to comment
Share on other sites

Which Desktop Windows are you actually trying to install?  i.e. Windows 8.1 and Windows 10 are slightly easier just because you only need the B120i driver to see the logical drive you create in the SSA for the OS.  Windows 7 will also require the NIC driver in addition to the B120i driver.

 

For Windows 7 you will need the drivers from HP site for Windows Server 2008R2

 

For Windows 8.1 & 10 you will need the drivers from HP site for Windows Server 2012R2

 

Check Windows 8.1 Installs

 

https://youtu.be/fZoxCqetIhw?list=UUj-yKp1lch2-7pQ6YF073JQ 

Edited by Joe_Miner
Link to comment
Share on other sites

Here's a checklist I recently made for my Windows 8.1 installation on my ML10v2 -- It is virtually identical to how I recently installed Windows 8.1 onto my Gen8 so I modified it to show how I installed 8.1 on my G8

 

You can read the 8.1 installation on my ML10v2 here: http://homeservershow.com/installing-windo-proliant-ml10v2.html

 

 

 

Step-By-Step: Windows 8.1 Pro Installation on HP ProLiant ML10v2 Gen8 MicroServer

 

Note: I used the most current HP Service Pack ProLiant version 2015.10.0 and the most current B120i driver CP024079.exe

Unless otherwise stated all ISO files I ran in iLO4 attached to my ML10v2 as virtual image files CD ROM/DVD and folders were attached as virtual folders

·         Ran HP Service Pack ProLiant (“SPP”) ISO file in Automatic Mode to make sure all firmware was up to date

·         Ran SPP in Interactive Mode and selected HP Smart Storage Administrator (“SSA”) After ReBoot selected F5 during post to go into SSA to create a Logical Drive (“LD”) that I can load my OS (i.e. Windows 8.1 Pro update) onto

·         Created LD01 with 1 Samsung Pro 840 Corsair GT 240GB SSD in RAID0

·         Left remaining 4 HDDs and 1 SSD unallocated No other physical drives were in the Machine

·         Shut down the machine

--

Windows 8.1 Installation

·         Attached Windows 8.1 Pro x64 update (“W8.1”) ISO in iLO4

·         Attached folder containing B120i Driver in iLO4 I extracted from CP024079.exe with 7-Zip

·         I Signed in using a Local Account to make it easier for me to run SPP later (I could always add a MS account later)

·         I selected “Later” for the Windows 10 update so as to focus on the Windows 8.1 installation, YMMV – NOTE: When I went to Windows Update to begin downloading important Windows 8.1 updates I had to go under “Optional Updates” and deselect the Windows 10 update – Unfortunately, every time I went to Windows Update the Windows 10 Update was again selected so I would have to deselect it again.  I found a solution at the SuperSite for Windows – I uninstalled update KB3035583 and then hid it as specified at http://winsupersite.com/windows-10/how-stop-windows-10-upgrade-downloading-your-system

·         I next:

o   Changed screen resolution (personal preference YMMV);

o   Ran NETPLWIZ (personal preference YMMV – for the first few days there will be a lot of reboots so this is just a time saver for me);

o   Set Time Zone (personal preference YMMV);

o   Enabled Hyper-V (personal preference YMMV – this will be in my home lab);

o   Reboot;

o   Set Computer Name (personal preference YMMV);

o   Reboot;

o   Began running recommended Updates – multiple reboots;

·         When all Windows 8.1 updates are done then I attached SPP and ran HPSUM in Windows to update &/or add missing Drivers including SSA

·         In Windows 8.1 ran SSA to set-up additional LD’s of physical drives added later

Edited by Joe_Miner
Link to comment
Share on other sites

You can do the installation without using iLO4 -- you will need to install the SPP to a Bootable USB Flash drive, put the files extracted from CP024079.exe (the B120i drivers) on a USB Flash drive, and install the OS installation iso onto a bootable USB Flash drive

 

I've done it that way and have also done it with the SPP and installation OS's on DVD's and using an external USB attached DVD drive

 

Be sure not to attach any USB devices to the USB3.0 ports or the back -- those will not work until an OS is up and running

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • Haxsource
      By Haxsource
      Good afternoon folks!
       
      I have a question I was wondering if someone would know about. I have a Microserver Gen 8 with Vmware ESXI 7 currently installed on the MicroSD with AHCI enabled instead of RAID mode (dont find anything usefull in raid mode in my current setup other than booting from ODD, which I can just use as another Datastore instead).
       
      With that context being said, Im trying to enable the Agentless Management Service from the ILO with the drivers on the Vmware ESXI 7, but unfortunetly after installing and trying to start the service with:

       
      /etc/init.d/hp-ams.sh start  
       
      I get the following error:
       
      /opt/hpe/ams/amshelper: error while loading shared libraries: libnicmgmt.so.0: cannot open shared object file: No such file or directory  
       
      Makes sense following the Vmware ESXI HPE support matrix, since its only supported until Vmware ESXI 6.5U2 Pre-gen. But I´ve been reading lots of people having working setups doing the following:
       
      Install Vmware ESXI HP Custom Image 6.5U2 -> Offline Update to Vmware ESXI 6.7.
       
      I was wondering if installing HP Custom Image 6.5U2 with the drivers Agentless Management Service working and doing a full upgrade to ESXI 7.0 would do the trick, since its an upgrade not a clean install...so libraries should stay supporting older drivers installed.
       
      Does this make any sense?? Has anyone gone trough this alredy?
       
      Thanks!
    • netware5
      By netware5
      ***CRITICAL*** iLO 4 update available here. HPE requires users update to this version immediately. Potential vulnerabilities in network stack.
      VULNERABILITY SUMMARY
      A potential security vulnerability has been identified in Integrated Lights-Out 5 (iLO 5), Integrated Lights-Out 4 (iLO 4), and Integrated Lights-Out 3 (iLO 3) firmware. The vulnerability could be remotely exploited to cause memory corruption.
      HPE has released updated firmware to mitigate these vulnerabilities.
      References: CVE-2020-27337
    • oldwhs12
      By oldwhs12
      I have been running the WHS1 pack 3 for many years.  Unfortunately it is no longer working.  I got a Proliant microserver Gen10 hoping it will run it but was unable to install the software.  The software should run on most older PCs?

      Does anyone have the WHS1 running on the Gen10?  Also my WHS1 iso is Pack 1.  If I manage to install the Pack 1 can I find on the web the upgrade to pack 3?  Would I be forever stuck at Pack 1?  Any advice would be appreciated.

    • AVsonyfan
      By AVsonyfan
      All credit to schoondoggy for his original idea. A shame I am on the wrong side of the Atlantic to order an SDM kit as the import duties make it an expensive option, or would have if they were still available. I had to look around to see what alternatives I could find... and managed to find the bits needed on Amazon!
       
      I must admit I am rather pleased with the end result of this project and may repeat it on the other Gen8 MicroServer. The outcome is a server with a mirrored system drive on the internal B120i, and the main drive bays connected to an HP P222 card providing a RAID-10 data volume. This is pretty much my ideal setup for a stable resilient but small server.
       
      Sabrent 3.5" to x2 SSD Internal Mounting Kit (BK-HDCC)
      Amazon UK - https://amzn.to/32qEVou
      Amazon US - https://amzn.to/3h8Blom
      The kit comes with all the cabling you need and all the required screws to mount the drives and bracket.
      Two types of power splitter cables are included along with two SATA cables. The bracket holds two SSDs and provides a small gap between them.
       
      I mounted the bracket next to the PSU but leaving a 2-3mm gap to allow for some airflow past the SSDs in case they get warmed by the P222.
       
      Tips:
      Put some insulating tape along the underneath of the upper chassis rail next to the PSU and drilled three small holes.
      I used two strips on to stop the drill bit from walking across the metal. Drill with a 2mm first then a 2.5mm bit. This leaves enough metal for screws to thread in.
      Check and measure each hole against the bracket as you go so that they line up. Bracket is then fixed in place using the provided screws (see photo).
       
       
      The final part of the puzzle is another Mini-SAS to SATA cable the same as the one connected to the internal drive bays.
      This is an SFF-8087 Mini-SAS [male] connector to 4 SATA [female] header cables. The 50cm cable from Jyopto works great and not too much spare to lose within the system.
      Amazon UK - https://amzn.to/2CXAzgb
      I could not find it on Amazon US site but there was one from CableCreations that same length.
       
      Just need to add your choice of SSDs and cable up to B120i port.  I went with Samsung 860 Pro SSDs for the longer rated lifespan of write cycles.
       
       
      I decided to forget about an internal DVD/RW drive and opted for an external HP F2B56AA slimline drive that can be plugged into the USB of either system.
      Amazon UK - https://amzn.to/2EgSSxD
      Amazon US - https://amzn.to/326uFmL
       
       
      Sabrent also make a really good quality 2.5" to 3.5" bay converter adapter (BK-PCBS) that I have used in the EX490/X510 to convert from HDD to SSD system drives.
      Amazon UK - https://amzn.to/3jbYBmT
      Amazon US - https://amzn.to/335kXQz
       
      Hopefully this information will prove useful to some looking to update their MicroServer.
       
       
       
       

    • gru
      By gru
      Hi! I am planning to buy a Microserver Gen10 Plus E-2224 for a small business, and want to add as much disk space as possible. I already have the older Gen10 with 4x4TB HDDs in RAID10 (effective capacity 8TB) and a 2TB SSD in the 5th slot (which is missing on the new G10 plus). The max stated capacity on the HPE site seems to be limited with their own enterprise HDDs, so I'd like to see if I can go for bigger disks. The server would be running a sort of an application which collects lots of data from devices, and the data tends to grow over time (1-2TB per year), and I'd prefer not to worry about the capacity for the next several years.
       
      My primary concern is the max capacity (max single drive capacity + max total RAID capacity with the Smart Array S100i) I can reliably install. If possible, some actual setup which has been shown to work with 32GB RAM and its limited 180W power supply? I was also planning on upgrading it to 32GB. If I am buying a 16GB RAM server, does this means it has both slots occupied with 8GB modules and I need a 2x32GB kit? For the os SSD, I won't have the PCIe slot available because we need to insert a certain GPS PCIe card that the server uses for time synchronization. So, if I want an SSD, this means I should use something like 1xSSD + 3xHDD in RAID5, instead of RAID10?  
      I've been planning to install 16TB Seagate Exos X16 drives, with rated max operating power at 10W (6.3W for random reads/writes). Does this seam feasible?
       
      Thanks a lot for your tips!
×
×
  • Create New...