Jump to content
RESET Forums (homeservershow.com)

I used to think I was smart... Then I tried to configure VOIP on my Sophos UTM 9


azcoyote
 Share

Recommended Posts

So I have the simplest implementation.

 

Sophos 9 fully up to date

PPPOE works great

Outbound rule allows all network to do whatever

 

I have a VOIP provider that terminates SIP for me.

I have a FreePBX server that acts as a phone system.

I could make these work behind every other firewall I have owned.  I am stumped.

 

In the simplest fo terms, can anyone tell me what rules to create enable etc?

 

I have Hosts defined for the external server and internal server and internal SIP handset.

I have protocols defined in services

 

I have even turned on VOIP --> SIP and set the networks as described in documentation.

 

My PBX says it is registered to the SIP provider.

Inbound calls do not receive audio channel but they ring.

 

Outbound seems to just do nothing.

 

I know this cannot be that difficult or complex for a home PBX terminated to a SIP provider.

Anyone out there able to give me some tips, pointers, directions, Ouja commands, elixer recipes, or straight up voodoo spells??

I will take anything at this point....

 

Thanks!

W

 

 

 

 

 

Link to comment
Share on other sites

So I solved this.... by using a STUN server on my PBX.  GRC still shows me locked down tight so I guess that is good.

As to the rules?  No idea....

Link to comment
Share on other sites

I haven't had voip for a while but it seems to me you would need some port natted through, do you have any details about what ports are used etc? 

Link to comment
Share on other sites

Try this method see if it helps, I am using an old RT32P2 for VOIP service in my home, I give it a fixed lan ip

 

In "Network Definition" I created a Host for it (client) and also create a Host for my VOIP service provider (server)

 

then in the "Network Protection - VOIP" I enable SIP protocol support and put the "server" under "SIP Server Networks"

and put "client" under "SIP Client Networks" 

 

and voila, my VOIP works, according to SOPHOS this will create some hidden firewall rules to enable the SIP protocol 5060

 

a side note here

I had similar experience at the very beginning, I believe I read somewhere that there are bugs in firmware require you to open some RTP ports (range depends on service provides) in addition to all the configs you've done in order to make it work.

 

I tried it works,

 

And I reinstalled the system and setup VOIP as above and then upgrade firmware, this time no RTP ports rules required, VOIP still works, interesting

Edited by CarsonKT
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...