Jump to content
RESET Forums (homeservershow.com)

Can't remove device for client


Recommended Posts

I added a new PC the server and made backups.  The PC failed shortly after purchase and was returned.  I am now attempting to "Remove a Computer" to delete the PC from Devices.  I continuously receive a message "An unknown error prevented removal of this computer.  Please try again."  I've run "Repair Backups" and also attempted to remove with the archive feature both checked and unchecked.  No luck.


I am able to remove other devices on the serve, just this one doesn't work.  Has anyone run across this and resolved it?  If not, I may be rebuilding my server over the holidays.  Thank you in advance for any assistance you may offer.

Link to comment
Share on other sites

I have the same problem.


In my case, I have tried two extra steps.


1.  Used the native Powershell Cmdlets Get-WssComputer and Remove-WssComputer.  Still cannot delete entry.

2.  I had de-commissioned the image, so was able to put the HDD back in the microserver that was the original device. I did this and the device continued to backup, etc, but I still couldnt remove it.


I would also be interested in how to resolve, as the continual alerts that I havent backed up this client recently are an annoyance.




Link to comment
Share on other sites

  • 1 month later...

I was able to correct my issue.  I did two things from the time I started working on it until I finally was fully successful.  Not sure which one actually did it, I'm thinking it may have been the last item, but I can't go back to find out.


First I have had my server OS backing up to a drive twice daily.  I  looked at the offending client and determined the date of the initial backup I did upon connecting it to the server.  I then went restored a back up earlier than that date.  Since this was before I had converted a majority of my clients to Windows 10, It put the backups it didn't recognize into archived computers.  I then had to reconnect all missing Windows 10 machines and reconfigure their backups.


I then tried to remove the offending client from the archives, but continued to fail.  I tried Repair Backups without success.  At least I'd stopped getting the warning about doing a back.


While working on backing up all my clients, an error popped up saying there was a problem with a partition on a drive.  I don't recall the exact name it showed, but I couldn't locate it when I went into Storage and Hard Drives.  So I ran Check and Repair on all of them.  


I then tried to remove the client again and received a message about the service not running.  I did a Restart under the Client Restore Serves tab of Client computer backup settings and tools even though it showed it was running.


After that I was able to successfully remove the client.  I'm thinking that if I had originally ran Check and Repair followed by Restart I would have corrected the issue, but the drive error had never appeared before, so I didn't even consider it at the time.

Link to comment
Share on other sites

  • 1 year later...

Thought I'd add my resolution: Add a computer with same computername using connector install, then delete the 'zombie' version with a stab to the head, err I mean remove computer, but be sure it's the zombie!  Other factors: Both were Win 10, had same description and I happened to have installed Client Restore service (Win Assessment and PE package as hinted to above prior to these steps)  Hope this helps someone with the issue.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • Rodf
      By Rodf
      I've got a Synology router, which I totally love!! (I was advised to get one here on these forums and believe me, that was wonderful advise!!) I thought I'd get onto my Synology web interface, was checking the devices connected. I noticed 3, all connected to the 2.4 GHz Wi-Fi band. They all have names like this: ESP_3AE9D7. I can ping them fine. I tried FTP'ing into one of them, but the connection was refused. So, how do I go about identifying what these devices are?
    • TwoWheels
      By TwoWheels
      I'll try to give a l the pertainent details.
      I have a Lenovo Flex 4 1580 that came with a 512GB Liteon SSD. That drive failed, and I'm trying to replace it with a 1TB Sandisk SSD.
      I used network PE boot to launch the restore, and then used ctrl-alt-shift to run diskpart. In diskpart, I created the two partitions on the existing drive, a 1GB WINRE_DRV partition and the remainder of the disk (I think) as a primary NTFS partition (which came out to 930GB approx).
      After restoring 100% (0% remaining, more precisely), it timed out and gave this error:
      [08/19/2019 00:33:04 664] RestoreHelper::FixBootBlock: fixing boot block [08/19/2019 00:33:04 664] RestoreHelper::ExtendVolume: extending the volume [08/19/2019 00:33:27 664] Restoring ESP [08/19/2019 00:33:27 664] existing offset: 0x0, size: 0x4400 [08/19/2019 00:33:27 664] existing offset: 0x4400, size: 0xfbc00 [08/19/2019 00:33:27 664] existing offset: 0x100000, size: 0x6400000 [08/19/2019 00:33:27 664] existing offset: 0x6500000, size: 0x8000000 [08/19/2019 00:33:27 664] existing offset: 0xe500000, size: 0xe891900000 [08/19/2019 00:33:27 664] Found existing volume [08/19/2019 00:33:27 664] existing offset: 0xe89fe00000, size: 0x41000000 [08/19/2019 00:33:27 664] existing offset: 0xe8e0e00000, size: 0x1fbe00 [08/19/2019 00:33:27 664] FormatPartitionEsp called for disk \\?\PhysicalDrive0 [08/19/2019 00:33:27 664] Formatting ESP partition at offset 0x8100000 [08/19/2019 00:33:27 664] ERROR: FormatPartitionEx failed, error 0x80042405 [08/19/2019 00:33:27 664] ERROR: FormatPartitionEsp failed, error 0x80042405 [08/19/2019 00:33:27 664] RestoreHelper::T_Restore: failed to restore ESP, error 0x80042405 [08/19/2019 00:33:27 664] RestoreHelper::T_Restore: restore complete with return value 536870914 [08/19/2019 00:33:27 664] ERROR: CDialog_Restore::Completed failed, HR=0x80070002 (at func: CDialog_Restore::Completed, admin\serveressentials\backup\pc\bmr\restorewizard\dialog_restore.cpp (97) I tried the instructions in Client BMR failed for UEFI machine in advanced mode , but the calculation in powershell yielded a non-integer, negative number of -2048.74120616913. 
      Based on the article, I'm assuming that instead of padding, I need to reduce the size of SOMETHING by 2GB, but I'm not clear how to do that so it lands on precisely the same address, particularly because of my fractional results from the powershell calculation.
      Is there a way to determine the EXACT sizes for the WINRE_DRV, Windows, EFI, and MSR partitions from the backup itself. It seems odd that it handles what should be a straightforward restore so poorly (and manually). the Restore UI provides "human readable" sizes, but what is really needed are exact sizes in MB blocks, apparently.
      Thanks for your assistance. This was my primary client machine and I really need it back!
    • RobWu
      By RobWu
      Hi all,

      Maybe a silly question, but can you do a full restore of a pc, but on a new (and different sized) disk?

      I have one pc that has a failing disk, and I can go the clone(zilla) disk to disk route to move the data over, and resize it to the new size.
      But I was wondering if it's possible to use the USB restore stick in a way that you can do the same?
      I cannot seem to find any good info on this online.

      If not, this would be a nice addition to the restore tools... ;-)
    • tswalker
      By tswalker
      I have not actually tried this yet, but was thinking about it...  can the connector be added to a server for remote management via the devices list in Essentials portal?
  • Create New...