Jump to content
RESET Forums (homeservershow.com)

Drivepool / Disk issue


iandrews
 Share

Recommended Posts

I posted this on the StableBit forums, but know others here use it, so thought I would post here as well. 

 

I am running Windows 2012R2 on my Gen8, and I have 4 * 3 TB drives in a pool, with 2 * data duplication set.

 

On Sunday I woke up to an alert from Scanner saying I had a bad disk. The GUI showed that the overnight (monthly) scan had detected a bad sector on one of my disks. I ran the file identify / recovery tool, and that said no files were affected. I then marked all the sectors on the disk as unchecked, and started a scan again, and this time all completed ok. I assumed that either there wasn’t really a bad sector, or that the disk had auto re-mapped it, however the SMART info doesn’t show any remaps.

All was ok until this morning, I woke to several errors from my overnight file copy backups. I seems that they wasn’t able to write to several folders on the pool. I checked for a few of the folders by looking in the hidden pool folders and that showed that (for the few I checked) one of the duplicated copies were on the same disk that I had issues with on Sunday. When I tried to open folders / files (sometimes at the top level, sometimes several sub folders down) I got  “G:\PoolPart….etc…etc   the request failed due to a fatal device hardware error”.

 

Scanner shows the disk as ok, and it’s on-line etc in windows Device manager. I tried creating a folder and file on the disk outside of Drivepool, and that worked ok. I tried a chkdsk but that came back “the type of file system is RAW. CHKDSK is not available for RAW drive”.

So, something not right, but now how best to proceed. Thinking a server re-boot will either sort, or will totally take the disk down. Wondering if it’s worth removing the disk from the pool first, but if I do that will Drivepool then re-duplicated data that is now not duplicated, and how will it handle the fact that it seems data isn’t readable.

 

Thanks.

Link to comment
Share on other sites

Update:

 

So, I tried to remove the drive from Drivepool, I selected remove, and then left the 2 tick boxes blank, but it came up with Error Removing Drive, and clicking on Error Details comes up with "The request failed due to a fatal device hardware error". So I tried again with the Force damaged driver removal and duplicate files later check boxes selected, but got the same.

 

Went into Windows Device Manager, and selected a Rescan, this showed 2 of the disks as "Not initialized", I then did a Rescan Disks, and this now doesn't show them as all.

 

The disks are attached to a M1015 card in IT mode, and the Windows GUI for that is showing 4 disks, however 2 are showing a lack of info such as size and serial number.

 

I then rebooted the server, and watched it come up. The M1015 BIOS showed all 4 disks, and the "details" for them. Then when windows came up all the 4 disk were showing in "My Computer", and also in DrivePool.

DrivePool did a re-duplication, and it came across 1 file that it said was different between 2 disks, so I told it to fix.

So, will just have to wait and see what happens over the next hours / days / months. Not sure why Scanner didn't pick up any issues, I did get a "missing" disks error from it, but that was only after I did a disk re-scan in Device manager last night, and that's when they "disappeared" from windows.

Link to comment
Share on other sites

Well, it looks like disks are being dropped / going offline in Windows / form the M1015. Sometimes windows shows them as missing, other times not and I just get a error message trying to access the disk directly, or when accessing a folder stored on that disk via Drivepool.

 

Most times a cold reboot brings them back, but last night even that didn't work.

 

So I re-seated all the cables last night, and that brought all the disks online again, but I did do all the cables at the weekend as well, bar the Molex Y connector under the ODD, and that only lasted 1 day or so before they started dropping again. Seems to happen overnight when backups are running, and there would be high disk access,

 

So, thinking it's either the M1015, but a SDD off the other port is ok, so maybe its just one of the ports. Or I'm overloading the power, either the whole supply, or the wires leading to the Molex under the ODD bay, or maybe an issue with the Y splitter, but again, the disks off one of the branches of the Y seem ok (but then they are SSD's and not HDD's). Or the SFF 8087 cable.

 

I do seem to have had various disk issues with this server, from 4 HGST disks showing Predictive failure, to some WD Reds dropping out of a Raid 5 array on a P212 card (hence why I got the M1015).

 

Thinking of just upgrading to a ML10 V2, which I can get for £280 (after cashback) with a E3-1220V3 and 8GB ram. Then selling my E3-1220l V2 to part pay for it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...