Jump to content
RESET Forums (homeservershow.com)

Restore Client Backup to SSD


byronomo
 Share

Recommended Posts

I want to replace the hard drive in one of my client PCs with an SSD of the same capacity (500GB).

 

Are there any steps beyond the normal steps to restore a client that I need to do due to the SSD?

 

 

 

The OS is Win 7 Pro (64-bit) and I already have the network and video drivers on the USB stick that I will boot from to initiate the restore.

 

Link to comment
Share on other sites

The restore mechanism should not be able to distinguish between an SSD and a spinning HDD.  Just make sure the partitions are the same size or larger from the source to the target.

Link to comment
Share on other sites

I have upgraded from a spinner to an ssd without problems using the bare metal restore. My ssd was smaller than the hard disk and I had no issues.

Link to comment
Share on other sites

Thanks for your replies.  I think I was able to get it done.  I need to do a bit more testing to make sure, but the machine was able to boot.   I did encounter some unexpected wrinkles either because I didn't know what I was doing or because of a particular quirk with that PC.  Here are the steps that I went through, in case it helps someone else, or in case someone can tell me where I went wrong for next time:

 

  1. I made sure that I had a successful backup of the client PC whose drive I was replacing on the WHS.
  2. I created a bootable USB drive (4GB in my case) and copied the contents of the WHS restore CD to that USB Drive.
  3. Using the WHS console, I viewed the files of the most recent backup of the client PC that I was upgrading and copied the folder called "Windows Home Server Drivers for Restore" to the root of the bootable USB.
  4. Since the client PC is 64-bit, I went and found the 32-bit drivers for the network card in the client PC and copied them into the "Windows Home Server Drivers for Restore" folder on the USB (from step 3)
  5. I replaced the spinning hard drive with the new SSD drive (both 500GB) in the client PC. Reconnected a keyboard, power and a LAN cable.
  6. With the new SSD installed, I booted the client from the USB stick. 
  7. I selected the option that I was restoring a PC with "More than 512MB of RAM"
  8. The screen popped up asking me about drivers.  There was a RealTek ("Realtek RTL 8168/8111 Family PCI-E Gigabit Ethernet NIC (NDIS 6.0)") Network driver already detected. 
  9. In the past, when I've restored a 64-bit machine, I've ALWAYS had to scan the USB for it to pick up the 32-bit drivers, so I selected the option ("Install Drivers") which scans the USB for the proper drivers.
  10. Try as I might, I could not get the restore process to load drivers that worked, so I had no network connectivity. The problems I encountered were similar to the OP here:https://social.microsoft.com/Forums/en-US/14499b06-eabc-463b-9d1c-ca526f2c7efb/cannot-restore-win7-pc-from-whs-server-drivers-not-loading?forum=whssoftware
  11. I tried downloading 32-bit drivers (Vista) from RealTek and Lenovo (the manufacturer of the client) and couldn't get past this step.
  12. Not to concede defeat, I regrouped and decided to try another approach.  I took the SSD out of the client PC, mounted it to another PC using a dock and booted the other PC from a DIFFERENT USB stick (with the appropriate drivers for that PC).
  13. I was able to get connectivity and connect to the WHS and find the PC that I wanted to restore to the SSD.
  14. The restore process couldn't see the SSD in the dock because it hadn't been formatted.  I selected the option ("Disk Management", I think) that lets me see all drives on the system and I partitioned the SSD into a single partition, made that partition active and formatted the SSD (it would only let me select NTFS).
  15. I then restored the "C:" drive from the WHS backup to the SSD (I didn't do anything with the 100MB "System" partition--perhaps this was a mistake).
  16. After restoring the backup, I re-installed the SSD in the client PC that I was upgrading and tried to boot the PC.  It wouldn't get past a message that said "BOOTMGR is missing  Press CTRL+Alt+Del to restart"
  17. I then created ANOTHER bootable USB, and copied my Windows 7 Install DVD to it.
  18. I booted the client from the Win 7 USB and entered the "Advanced Boot Options" by pressing F8 while booting.
  19. Eventually, I was able to find the option to install windows and after selecting that option, there was an option to "Repair your computer", which I selected.
  20. I then selected the option for "Startup Repair" and followed the prompts on the screen.  The process sent me through these steps several times until finally prompting me to remove all peripherals from the USB port (my cue that the process was finished and to take out the USB stick).
  21. The PC was able to boot into Win 7 after that.   It was late by that time, so I didn't have a chance to fully test the PC.

 

I'm sure that there was a better way to skin this cat, so if anyone knows where I went awry, it might help others to point it out.

 

 

Thanks again for your replies!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...