Jump to content
RESET Forums (homeservershow.com)

Low eSATA transfer speed


snoopyx
 Share

Recommended Posts

Hey Guys,

 

hope everybody is enjoying there sundays. I ran into a problem a little while back and could not fix it. It all started by buying a new 4TB HDD as a Backup for the stuff stored on my N54L. I plugged the HDD into a spare eSATA external enclosure and was disapointed by the low transfer speeds (10MB/s). There should be more possible as I was trying to Backup rather large data, Acronis System Backups 10-50Gb in size.

 

But 1st my setup:

 

N54L with 8GB ECC RAM, headless Ubuntu server 12.04 LTS on 16GB USB jump drive on internal USB, Original Bios, no RAID

 

As I already said I do not exceed 10MB/s in transfer speeds, even though more should be possible!? I scanned the HDD with HDD Tune Pro for Bad Sectors but non were found, Even though it has already reallocated 8 sectors. To test that, I used another perfeclty fine 2TB HDD plugged in the external case and again a maximal of 10MB/s. I enabled the Write Cache in the BIOS but still nothing.

The external enclosure is a RaidSonic Icy Box IB-351StUS. I tried to find some solution but all I tried didn't help. I asked in a couple of different forums but the problem was that the Linux guys thought its a Hardware issue, while the Storage people believed its due to the OS. So I kinda hope I'm here at the best place where both expertises get together.

I use the following rsync command to copy the files:

rsync -rltRDvu --modify-window=1 --progress --delete --delete-excluded --exclude-from=/home/ivan/BackupExclude.txt /source-path /target-path

First I had the 4TB HDD formatted as NTFS as I wanted to be able to read the Data from a Windows PC as well. But in addition I also tried ext4 formatting without resolving the issue.

 

Any idea would be much appreciated, as this problem is driving me crazy. I just want to have a rather quick possibilty to Backup my data.

 

Cheerio

Link to comment
Share on other sites

Again me, I run a couple of Benchmarks on the 4TB Toshiba and the 2TB WD. There is no difference in the Benchmarks, neither under Windows 7 or a Live Linux Distro. Also no bad sectors on the HDDs, even though the 4TB Toshiba has 8 sectors reallocated.

I then tested by copying a couple of files with rsync (rsync -ah --progress /Source /Target) on the disks formatted as ntfs and ext4. As expected when formatted as ext4 I achieve sligtly higher transfer speeds in comparison to ntfs (45MB/s vs 35 MB/s). But still far away from the observed 10MB/s. I thought that maybe the additional flags I use for the Backup (rsync -rltRDvu --modify-window=1 --progress --delete --delete-excluded --exclude '/path to textfile' /Source /Target) cause the slow transfer speeds but again no. The transfer speeds are the same as w/o the additional flags. All these tests were done running the HDDs in the external enclosure.

 

To sum up:

- the HDDs should be fine

- the external enclosure is not limiting

- rsync can achieve much higher transfer speeds albeit the flags set

 

So is the eSATA port on my N54l limiting with the stock BIOS? What kinda speeds did u achieve? I really run out of ideas here....

Link to comment
Share on other sites

  • 1 month later...
I just flashed the latest BIOS and the Sata drivers haven't been updated in 2 years according to the asus downloads page, so I have all those.

Seems odd that the mobo would have an eSATA port just because, and not actually have it working to eSATA standards
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...