Jump to content
RESET Forums (homeservershow.com)
brianmullins

Replace WSE 2012 Essentials domain controller

Recommended Posts

brianmullins

Hey guys,

 

Need some advice/direction. I've got a WSE2012 (not R2) server set up and have been a bit neglectful of it. Currently the Storage Spaces drive that I had created is totally hosed as it ran out of space. I added a drive a few months back with the intention of moving/removing some old backups, but time got away from me and it died again once it filled up. It has no data other than backups of my desktop machine on it, and that's not been working for 6+ months. I've got Crashplan on my desktop, too, so i'm not in any immediate danger of losing data.

 

What I'd like to do is just wipe the machine and start over. However, it's my domain controller (only my desktop machine is joined), and I'm worried about having to move my user profile on my desktop to a new domain. Can I just rebuild the server, name it and the domain the same as currently and then rejoin my desktop without issues?

 

Thanks in advance. I trust you all way more than any other site to lead me in the right direction.

 

Jim and Dave (and anyone else who's thinking this...): I know, I should have the server backing up, too. That's the goal for the new setup. And I'll be avoiding Storage Spaces. What a pain.

 

Thanks,

 

Brian

Share this post


Link to post
Share on other sites
Drashna Jaelre

No, you can't just wipe and rebuild.  
Specifically, when you create the domain and accounts, it creates unique IDs for each account. These are not retained on the new system. 
Nor is the "domain trust" retained. 

 

There isn't a good solution here, though, if you just want to wipe out the backups, you can delete that folder and start from scratch, without having to rebuild the domain controller (or even break up the storage spaces array and recreated it ... or use something else).

 

 

And if you want to use something beside Storage Spaces, look into StableBit DrivePool or Drive Bender. Either are far better solutions. 

(I'm biased, I work for the company that produces StableBit DrivePool). 

Share this post


Link to post
Share on other sites
brianmullins

Hey Drashna,

 

Thanks for the reply. I figured it would be full of pitfalls. I've gone down the path of creating a hyper-v vm of wse2012r2 on my desktop machine, set it up as a second DC, transferred the FSMO roles to the new server, and am about to wipe the old server. Once I get it set up again I'll basically do the reverse and I think i should be OK. 

 

That sound like it should work?

 

Definitely going with Stablebit this time...

 

 

Thanks,

 

Brian

Share this post


Link to post
Share on other sites
Drashna Jaelre

If you have the backup/secondary, then you should be okay, I think.

I haven't messed much with that, but in theory....

 

 

Worst case, if it doesn't... you should still be able to log into the domain account on the client system for now. You'd want to migrate everything off of it, make sure you have a local admin account (run "lusrmgr.msc"), and then leave the old domain and join the new domain. 

 

 

And glad to hear it. Hope you enjoy StableBit DrivePool (and check out StableBit Scanner, if you haven't already or haven't planned to, yet).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • Umfriend
      By Umfriend
      Hi all, new here and WSE noob.
      So I have a server running WHS2011 and I want to go WSE2016 (or WSE2019 if it will still offer client backups, web access etc.). So I installed a evaluation and am testing with old unused computers. Now I know that there are two things some talk about when using WSE in a SOHO setting: not joining the domain and not having WSE as the DNS server.
       
      Now my question is basically this: I connected a client with defaults (so no hacks) and now I am wondering "why bother"? I don't understand what the reasoning is behind not joining the domain for instance. As far as I can tell, the user sees no difference between connecting to WSE2016 or WHS2011. But people are talking about it so there must be a catch I don't get.
       
      Edit: My clients would be both fixed PCs as laptops which would have to be able to work on other networks (but not connected to other servers or anything).
    • doliveira
      By doliveira
      Hi,
       
      At my home office i have a HP Microserver N40L and i use “Windows Server 2012 R2 Essentials”.
       
      On the past i had some initial configuration and instability problems with Anywhere Access + VPN, but somehow i finally have them working properly and stable for the last months. 
       
      But last week i needed to format the server and install a brand new and clean “Windows Server 2012 R2 Essentials”.
       
      I have made the installation, then made all the updates, then i have added some roles and features and then i went to setup Anywhere Access + VPN and it’s giving me 2 errors (one saying that i have port 80 and 443 blocked and other saying i have more than one router on my network).
       
      Both errors do not exist, because besides manual confirmation that ports are open, no network configuration was changed since last week. And if all was working in the past, now all should also work.
       
      I have already try to turn all off and then try again to run the Anywhere Access + VPN repair wizard and the errors are still the same.
       
      I have already pass too many hours trying to identify what is wrong… and i can’t wait to much longer.
       
      So i have 2 requests to make to anyone reading this:
       
      1- If anyone has any idea of what is the problema, and wants to share the advice, great! Please do.
       
      2- I’m willing to hire and pay to an expert to remote login my server and solve the problem. I can provide remote access and be your remote eyes so you can see all the network setup. If you can do this, please reply to this thread with your email or send me a PM.
       
      ---------
       
      My network setup is as follows:
       
      ISP Router (in bridge mode) > Router TP-Link ER-5120 > Smart Switch TP-Link TL-SG108E
       
      Then Smart Switch then connects:
       
      - Port 1 to Router
      - Port 2 to Access Point TP Link TL-WA901ND (with QVLAN enable for private and public wifi networks)
      - Port 4 to Unmanaged Switch TP-Link TL-SG1016
       
      Then the Unmanaged Switch connects to my server and my home office computers.
       
      --------
       
      Thanks
       
    • doliveira
      By doliveira
      Hi,
       
      I’m setting up my small office network and on my server I will use the “Windows Server 2012 R2 Essentials” and I will want to enable and use the “Anywhere Access” and “VPN” build in features to have remote access to my server from outside.
       
      Regarding this, my router uses as factory default the port 80 to access the admin interface. 
       
      But I think I should change this in order for my router not to be visible from outside world, and also not to conflict with any of the Windows Server services, correct? It’s a best practice to do this correct?
       
      If yes, I really don’t know which port I should use. I’m think on using port 8080 so the router access from inside my network will become: http://192.168.0.1:8080.
       
      So can anyone please share your advice on which port I should use for my router admin interface access?
       
      It must be a port that can only have access from my internal network and it must be a port not used by common services in order not to create conflicts. 
       
      Thanks
       
    • tswalker
      By tswalker
      I have not actually tried this yet, but was thinking about it...  can the connector be added to a server for remote management via the devices list in Essentials portal?
       
       
    • Joe_Miner
      By Joe_Miner
      As sort of a continuation of the Testing I started over at http://homeservershow.com/forums/index.php?/topic/6016-performance-test-create-and-measure-performance-of-storage-spaces-pool-3-virtual-hdds-in-wse2012r2p/ I created a Storage Spaces Pool in Windows Server 2012 R2 Essentials Preview using 3TB Seagate ST3000DM001's as the Physical HDD's in my SSPool. 
       
       
       

       
       
       
       
      You can also link to it here youtube.com/watch?v=lebo9o5sPf4
       
       
       


×
×
  • Create New...