Jump to content

  •  

  • Photo

    Something wrong with file "HomeServerConsoleTab.HP.dll"


    • Please log in to reply
    8 replies to this topic

    #1 Shepherd Jim

    Shepherd Jim

      HSS 1 Post Wonder

    • Members
    • 7 posts
    • LocationBristol, Maine USA

    Posted 28 March 2012 - 10:15 AM

    When I am able to get into the console of my HP 475 MediaSmart I am not able to copy or move any files from either the "Public" directory or any of the User "Shares". I can SEE the files on the WHS, but I am not able to access them via "drag and drop", "copy/paste" or any other means.

    When I try to log into the WHS Console I often wind up in an empty light blue window. I'm no expert but attempting to access everything via Remote Desktop Connection does not seem to work.

    I sometimes see a notice telling me that a previous attempt to open the WHS Console was unsuccessful because there was a problem with the file "HomeServerConsoleTab.HP.dll" -- the notice tells me I should disable the add-in with which the file is associated, but I have not been able to find the file anywhere.

    Thinking --------------------------------------------------------
    I'm becoming more and more frustrated with my WHS. Lately it seems like I'm having a new problem every three months or so. A recurring problem would be easier to deal with as I would just apply the fix I'd learned before. Inasmuch as Microsoft themselves already pretty much tore the heart out of the "Home Server" I'm thinking I should just ditch the HP WHS appliance, take out the HD's and install them in another Drobo to run as a NAS and do Carbonite on my and my wife's laptop hard drives.
    • 0
    -- i wish i knew then what i know now ---- i wish i knew then what i know now --

    #2 diehard

    diehard

      HSS Elite

    • Moderators
    • 1,618 posts
    • LocationMontreal

    Posted 28 March 2012 - 10:29 AM

    My 1st guess as to access to the shares is a permissions problem. Check under the Users Tab in the Console for the user you are using. Check what access to shares does it have. read, write, none. If that doesn't work. uninstall the connector at the PC and reinstall. open a web page to http://yourservername:55000 to download the connector.

    The dll should be in C:\\Program Files\ Windows Home Server, but I wouldn't delete/remove it if I was you. If you want you can move it to the desktop, then restart the console, if that doesn't work, copy it back.

    let us know what happens.

    Do you get the "HomeServerConsoleTab.HP.dll" when you open the Console ? Does it give you an option to retry or ignore ?
    • 0

    EX470 modified BIOS BE-2300 CPU 4Gig ram, 4 2TB HDD. DX4000 with 4 2TB HDD Storage Server2008 R2 Essentials.
    Microsoft MVP - Windows Home Server


    #3 ikon

    ikon

      HSS Elite Master

    • Donating Member
    • 13,534 posts

    Posted 28 March 2012 - 10:31 AM

    Up to you of course, but if you are game for some troubleshooting:
    • first, make sure you're having the RDP and Connector issues from all your computers.
    • shut down WHS, remove 1 drive at a time and check them all. I would use SpinRite, but there are other tools.
    • you could also use Stablebit Scanner to check the drives while they're still in the WHS, but, if you can't get to the Console, it's going to be difficult to get Stablebit Scanner installed.
    • after ensuring you've got your data backed somewhere else, simply reinstall WHS.

    • 0

    If at first you don't succeed, do it like your mother told you.


    #4 diehard

    diehard

      HSS Elite

    • Moderators
    • 1,618 posts
    • LocationMontreal

    Posted 28 March 2012 - 10:43 AM

    Check this out.

    http://www.mediasmar...nsoleTab.HP.dll


    removing the .dll will remove the HP Tab.
    • 0

    EX470 modified BIOS BE-2300 CPU 4Gig ram, 4 2TB HDD. DX4000 with 4 2TB HDD Storage Server2008 R2 Essentials.
    Microsoft MVP - Windows Home Server


    #5 ikon

    ikon

      HSS Elite Master

    • Donating Member
    • 13,534 posts

    Posted 28 March 2012 - 10:51 AM

    Check this out.

    http://www.mediasmar...nsoleTab.HP.dll


    removing the .dll will remove the HP Tab.


    That doesn't sound so bad :)
    • 0

    If at first you don't succeed, do it like your mother told you.


    #6 jmwills

    jmwills

      HSS Genius

    • Donating Member
    • 7,534 posts
    • LocationHuntsville, AL

    Posted 28 March 2012 - 12:15 PM

    If it's just one file, have you tried doing a restore of the server?
    • 0

    Windows 7 Desktop - Antec 100 Case, Intel D8H67BL, OCZ 550W PSU, Intel i3-530 CPU w/16GB G-Skill DDR3 1333 RAM
    Server 2012 - Fractal Arc Midi, CoolerMaster M600 PSU, ASUS P8H67V, Intel i5-2500 CPU w/32GBG-Skill DDR3 1333 RAM, 90 GIG OCZ SSD OS Drive – Roles: Hyper-V (WHS-SharePoint-DC-SQL-Exchange-WSE 2012R2), Print Server - Rocket RAID 2720 4 x 3TB WD Red
    HTPC Build - Silverstone GD05 Case,x 2
    Travel Laptop: Lenovo U310 13.3" Windows 8.1


    #7 Shepherd Jim

    Shepherd Jim

      HSS 1 Post Wonder

    • Members
    • 7 posts
    • LocationBristol, Maine USA

    Posted 28 March 2012 - 03:34 PM

    1) My 1st guess as to access to the shares is a permissions problem. ...<snip>...

    2) If that doesn't work. uninstall the connector at the PC and reinstall. open a web page to http://yourservername:55000 to download the connector.

    3) The dll should be in C:\\Program Files\ Windows Home Server, but I wouldn't delete/remove it if I was you. If you want you can move it to the desktop, then restart the console, if that doesn't work, copy it back. ...<snip>....

    4) Do you get the "HomeServerConsoleTab.HP.dll" when you open the Console ? Does it give you an option to retry or ignore ?


    Hey John --

    1) I checked the Logon Name permissions in the Console and I have Full access for all Shared Folders,

    2) I can't get my browser to pull up anything at http://ShepJim:55000 "ShepJim" being my Username. I get a notice telling me that the server at "ShepJim" is taking too long to respond. Can I use one of the files in the \Software\ folder in the WHS to re-install the connector? How do I uninstall the connector?

    3) I looked for the dll in the dir C:\\Program Files\ Windows Home Server\ but the closest thing in there was "HomeServerConsoleTab.DeDupe.dll" -- I left that alone

    4) Yes, I get the choice of "Retry" or "Skip". Skip gets me into the Console.

    Something New: Okay, when I was last in the Console "Shared Folders"I I noticed that \Photos' status was a yellow ball and it says "Failing (Check Health)" -- How does one share/folder go bad? Could this be part of the trouble I've already identified or is this something else??

    I also see notice of "file conflicts" -- when I click on "Details" I see the names of 20 files (all files in the \Photos\ folder).

    I'm trying hard to stay organized and not panic, but I feel like I'm running around like the proverbial headless chicken -- seems like there's a problem everywhere I look.
    • 0
    -- i wish i knew then what i know now ---- i wish i knew then what i know now --

    #8 ikon

    ikon

      HSS Elite Master

    • Donating Member
    • 13,534 posts

    Posted 30 March 2012 - 08:21 PM

    You do have at least one good backup of your data, don't you?
    • 0

    If at first you don't succeed, do it like your mother told you.


    #9 diehard

    diehard

      HSS Elite

    • Moderators
    • 1,618 posts
    • LocationMontreal

    Posted 30 March 2012 - 08:43 PM

    Something New: Okay, when I was last in the Console "Shared Folders"I I noticed that \Photos' status was a yellow ball and it says "Failing (Check Health)" -- How does one share/folder go bad? Could this be part of the trouble I've already identified or is this something else??

    I also see notice of "file conflicts" -- when I click on "Details" I see the names of 20 files (all files in the \Photos\ folder).


    This usually happens when the index of the files don't match with the files. The index could be corrupt or the files could be missing. This could be due to a drive actually starting to fail. Maybe give the SMART addin a try to see if it finds issues with the drive.

    Also if the folder is duplicated, it could be that the files are not on the secondary drive. Somehow they got erased. What you can try is to find the files on shares and move them off to say the desktop. Then copy them back.

    4) Yes, I get the choice of "Retry" or "Skip". Skip gets me into the Console.

    Usually a retry will fix the issue for the next time. if it doesn't then try opening the Console on an other PC or do a Remote Desktop Connection to the server and open the Console there, then try back at the PC. It could just be stuck in a memory buffer. These tricks to fix usually solve issues that for the sake of a better words would be sloppy code writing. Hopefully your issue is not bigger.

    But keep asking.

    2) I can't get my browser to pull up anything at http://ShepJim:55000 "ShepJim" being my Username. I get a notice telling me that the server at "ShepJim" is taking too long to respond. Can I use one of the files in the \Software\ folder in the WHS to re-install the connector? How do I uninstall the connector?


    You should be using the server name not the user name. http://hpserver:55000
    • 0

    EX470 modified BIOS BE-2300 CPU 4Gig ram, 4 2TB HDD. DX4000 with 4 2TB HDD Storage Server2008 R2 Essentials.
    Microsoft MVP - Windows Home Server





    Skins By Invisioneers