• Similar Content

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
      Any help is greatly appreciated.
      Cheers Benny
    • felt
      By felt
      Bought this ML10v2 a few months ago and have been hitting wall after wall, frustrated- putting it away for a few weeks, and then trying again. I can not get it to boot from a USB and have not figured out how to recognize and identify drives!
      I have gotten iLO4 working with a valid key, I have updated the SPP, registered on who knows how many HP/HPE pages, looked through the documentation- but still can't get the machine to boot to my Linux USB for installation.
      This seems like a basic step, but I've kind of lost my objectivity at this point and wanted to ask for help. Is there something I need to do in iLO4 to have it recognize the install media or my drives? I can't seem to make sense of the Virtual Media field.
      I want to install Ubuntu 16.04 Server- HP/SPP says it supports Canonical. How do I get the machine to 1) open into BIOS? is it F2/F9/F10/F11 during boot? My POST sequence never seems to get past 10%, and then 2) recognize my hard drives, no matter what number SATA cable, it doesn't see them. I can only open the iLO4 manager from another computer on my network, so I can't open it on local host like the (very helpful) Joe Stutsman videos and instruction guides suggest.
      Anyhow, any input on this configuration would be appreciated. I know I'm missing something, but want to exhaust all options before I return this.
    • nlitend1
      By nlitend1
      I upgraded 2 identical systems (both running windows 7) to SSDs and restored images via WHS 2011 and noticed that one of the systems is not running AHCI mode (according to AS SSD benchmark and device manager). I made the 2 registry changes already in windows according to this guide....
      http://www.sevenforums.com/tutorials/61869-ahci-enable-windows-7-vista.html   I then made sure that the BIOS had SATA configured as AHCI (and not IDE). After reboot, I did not get prompted to install the AHCI drivers and the performance is significantly less with the system that appears to be running in IDE mode.   The following are two strange things:  1. Changing the BIOS setting to AHCI or IDE never gives me a BSOD. 2. Stablebit scanner states that both TRIM and NCQ are both working on the SSD and from what I can tell NCQ cannot run without AHCI mode.   This system apparently appears to be "stuck"... in what appears to be IDE mode...Any ideas on what to try at this point? Am i looking at a clean install or even worse... corrupted BIOS?    Thanks!   nlitend1
    • TheChallinor
      By TheChallinor
      Currently running the old and unsupported Bay version of the custom N54L firmware and looking to upgrade to Windows 8.1
      Appreciate there is an issue with the NIC stopping the upgrade as it's not supported, although there is a HP bios upgrade to fix this bug. 
      Obviously if I flash the bios to the latest HP version I will loose Sata II speeds on the ports that HP don't support OR I could get a NIC and keep the bios as it is.
      Just looking for ideas / suggestions on what other people have done, etc.
    • Jon Hill
      By Jon Hill
      How that a few here have opted for the HP Microserver I would like to pose a question /warn here about the power options.
      I jumped at this box to migrate to 2001 as I had issues with v1 box, and here in the UK 100 GBP was too good a deal to miss at the time.
      I run with the stock RAID 1 mirror on the first 2 * 2TB drives with the OS and my critical data then run a RAID 0 stripe on 2 more 2TB for video mainly recorded TV and ripped DVD’s.
      Due to the price and peace of mind I ended up with two boxed I am not sure about the recovery options for my data if the RAID(s) die as this RAID stuff is all new to me.
      Sorry to the question, I have not found a way to make the box sleep or remote shutdown, I did plan to run lights out on the box as I used it on V1 with no issues. I have the latest BIOS and tried the Light's Out pdf that can point to some checks to enable sleep but I think it is not supported at all on the box.
      Can anyone else verify this or know of a workaround. Not a major deal but I would like to run one box 24/7 then have the other as a backup destination NAS type thing waking and sleeping automatically.

Modified BIOS for Microserver N40L enables hidden features

540 posts in this topic

Question for the sake of clarity, I believe I read this on here but cannot seem to find the post (needle) in the forum (haystack). I flashed a G7 N54L with the MOD-BIOS so it sits at 041 -10/01/2013. I've made the adjustments I want and now I want to install W8.1 Pro for an htpc build. Seems I now need to create another flash drive using SP64420.exe and this will flash it to the latest HP factory BIOS correct? When I do this, it will essentially lock the hidden mods again, but leave them in the state I have adjusted to, but allow the onboard NIC to function correctly with Server 2012 and Windows 8?


Also, is there a list of non-functional items the BIOS-Mod seems to enable? i.e., I notice that it enables an NEC USB3.0 on-board controller but as far as I can tell this doesn't exist? Also I saw mention somewhere that someone had slipped in an SLIC 2.3 mod somewhere too? What exactly does this enable?



Edited by Helzy

Share this post

Link to post
Share on other sites

When I flashed with the factory SP64420.exe the BIOS flash returned my eSATA and ODD SATA ports (Ports 4 & 5) to IDE emulation mode (i.e. everything was reset to "factory" state).  YMMV.  You will need SP6440.exe (or its MOD version -- check the stickies for links to the Tobi MOD, YMMV) to run Win 8.1 or S2012R2 on the MS. 


NOTE: I've had no experience with the Tobi Mod so use it at your own risk.

Edited by Joe_Miner

Share this post

Link to post
Share on other sites

When I flashed with the factory SP64420.exe the BIOS flash returned my eSATA and ODD SATA ports (Ports 4 & 5) to IDE emulation mode (i.e. everything was reset to "factory" state).  


OK So I read that incorrectly. What is the date stamp on the HP factory BIOS from SP64420.exe?

Share this post

Link to post
Share on other sites

Per sticky => Version 2013.10.01(A) (15 NOV 2013)

Share this post

Link to post
Share on other sites

Indeed I saw that, I must have d/l'ed the Tobi mod the other day, however it does read still in the BIOS as:





the actual date stamp of the BIOS rev vs release date (15 NOV 2013) I assume was throwing me off.

Share this post

Link to post
Share on other sites



I downloaded and installed the o41100113-acpi-s3+s4_hotplug_fan-control.rar file. I got lot of new menu, but i have two problems:


1: on the main screen i see that the BIOS ID: 041, Bios Version 07/29/2011.

2: on the disn menu i doesn't see my disks. All of disks are non detected, but i see this on the boot menu where i can select the boot disk.


So this  is the latest modified bios? And that is normal that i didn't see any disks in the bios?





Share this post

Link to post
Share on other sites



I recently got a HP Microserver N40L and find it to be very noisy to setup in my Living Room so i bought a Noctua PWM Fan without realising that the Server needed a specific FAN Speed to Boot up.

Can the modded BIOS get around this Limitation?

Share this post

Link to post
Share on other sites

Has HP now blocked this fix from working on newer N54L stock, because ......... I'm not too damned happy :/

This is my OLD HP Microserver, you can clearly see an option for "OnBoard PCI IDE Controller", this option is MISSING on my new server :/






You can also see, when it does disk detection

All 6 hard drives are visible under AHCI.




On my new Microserver, the PCI IDE option seems to be locked in IDE mode (because the option is ENTIRELY missing)  and it only detects 4 AHCI disks and 2 IDE disks.

I'm 99.976% sure the hacked ROM was installed correctly by me, because the incredibly complex, weirdo options to the far right are there (very extensive north / southbridge menus, which I distinctly recall NOT being there on the stock ROM for the Microserver series)


Am I doing something wrong or was a change recently made?

Edited by wizzbang

Share this post

Link to post
Share on other sites

EDIT: Found the fix, it's ok - gotta change some settings in southbridge before AHCI works properly for all 6

Share this post

Link to post
Share on other sites

Hi All,


I am currently running BIOS version o41072911, what is the latest modified version available?

Could someone also let me know if there is any benefit to updating the BIOS?

I am running additional hard drives in the optical bay and I don't fancy playing with all the BIOS settings all over again if there is no real reason to update the BIOS.


Thank you

1 person likes this

Share this post

Link to post
Share on other sites

This links are not only not kept up to date but they are currently down.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now