Jump to content

  •  

  • Photo

    GO JUMBO OR GO HOME


    • Please log in to reply
    20 replies to this topic

    #1 ikon

    ikon

      HSS Elite Master

    • Donating Member
    • 12,268 posts

    Posted 13 August 2011 - 06:31 PM

    First, apologies for the length of this post. I understand if you say, "Forget it!".

    So, in a few other post threads I've alluded to an issue I've had with streaming Recorded TV and Movies from my WHSv1 to my HTPC. The issue is 'stuttering' or 'jerkiness'; very brief hiccups in the stream, at least with Recorded TV. They weren't enough to really interfere with enjoying the show, but they were noticeable.

    When I tried to stream a BD mt2s file today it was unwatchable; even the audio was totally broken up. Using 2011 made little, if any, difference.

    Today was the day to tackle the issue head on. There are a lot of variables. Is it:
    • something with my HTPC's ability to render
    • something with my Atom 230-based WHS
    • something with my network
    I first tackled my HTPC, cause it's so easy. I just copied a Recorded TV file I knew caused at least some stuttering to my HTPC from my WHS and played it. Perfect! No stuttering at all. Strike One against it being the HTPC.


    I copied a BD file to the HTPC and played it. Again, perfect. OK then, it is NOT the HTPC. On to step 2.

    Since there isn't a whole lot I can do with the WHS, I tackled the network next. The first test was to directly connect the WHS to the HTPC. I had to crimp a new cable cause the WHS is on the 2nd floor and the HTPC is on the main floor and I didn't have a long enough cable at hand. I have the proper tools and supplies, so no problem. I even have a PentaScanner to test the finished cable (which passed).

    I played the same 2 files that had worked perfectly from the HTPC, but from the WHS this time. I got the same levels of stuttering as I'd had when the WHS and HTPC were not directly connected. So, it doesn't really look like it's the ethernet switches or cabling.

    To test if it IS the WHS, I copied the 2 test files to my Win7 desktop computer and tried playing them. Again, I got the same levels of stuttering. I got the same results whether the Win7 computer was connected directly to the HTPC or via the LAN.

    All 3 computers are using Realtek NICs. I'm not necessarily the biggest fan of Realtek but, I have to admit, for the most part they seem to work fine. To bolster this, I recalled that I hadn't really had any issue copying the test files around the LAN.

    Alright, it seems not to be the HTPC, or the WHS, or the network hardware. What's left?

    At this point I'm thinking settings, specifically network settings. I connected the Win7 computer directly to the HTPC again. To test connectivity, I started each computer continuously PINGing the other..I then started changing the settings of the NICs. Nothing really made much difference until I hit the Jumbo Frames option. On both computers it was disabled. I changed it to 9k packets. There was a brief interruption in the PING responses, then they picked up again.

    I killed both PING sessions and played the Recorded TV test file. Perfect!. No stuttering, no jerkiness, audio is great. I stopped it and tried the BD file. Again, perfect! It started right up and played smooth as silk.

    I connected the Win7 and HTPC computers back up to the LAN and tried playing the files. Again, both were perfect.

    I changed the WHS NIC to use 9K Jumbo Frames and tried playing the files from the WHS. Again, perfect. Issue resolved it appears.

    One thing I always try to do when troubleshooting is go back and try to replicate the problem, to prove what I did was actually the fix. I changed the HTPC to disable Jumbo Frames. Sure enough, the stuttering came back, just like before. I re-enabled 9K Jumbo Frames. Oh no! It didn't fix the problem - the stuttering was still there.

    I RDP'd into the WHS to check it's settings. Sure enough, they were still set to 9K Jumbo. Ah crap; now what's the problem? Just as a test, I set the WHS to use 1514 byte packets, since it doesn't offer an option to disable, and OK'd my way back to the desktop. Then I went back and re-enabled 9K Jumbo Frames and OK'd back to the desktop again.

    Voila! The stuttering was gone again. It appears that the WHS negotiated down to 1514 byte packets after I changed the HTPC but didn't auto-negotiate back up again after I re-enabled 9K packets. Something to keep in the back of my mind.

    So the issue is resolved; it's been a good Saturday.

    As you can imagine, the WAF is huge! :)

    Apparently, size DOES matter. ;)

    I'm sure Jumbo Frames have been mentioned in other threads, no doubt by pcdoc/nocontrol. But, I'm not sure the subject has been the central focus of any thread, so I thought it deserved to be.
    • 1

    If at first you don't succeed, do it like your mother told you.


    #2 Greg Welch

    Greg Welch

      HSS Champion

    • Donating Member
    • 458 posts
    • LocationLas Vegas, NV

    Posted 13 August 2011 - 07:13 PM

    Just had alot of discussion about frame auto-negotiatioin in my cisco class. isnt a switch suposed to minimize collisions ?. hense help out auto-negotiatioin, dont like hearing the auto in auto neotiation is unresponsive ;(

    thank you for bringing this up as i am working through my network as well ill watch auto-negotiate.

    p.s. check out my little issue that spured my network review as well http://homeserversho...__fromsearch__1

    Edited by welchwerks, 13 August 2011 - 07:15 PM.

    • 0

    Synology DS1513+ backed up to IoSafe N2 with integrated Synology DSM


     


    #3 Greg Welch

    Greg Welch

      HSS Champion

    • Donating Member
    • 458 posts
    • LocationLas Vegas, NV

    Posted 13 August 2011 - 08:10 PM

    O.K. have some more info:

    found this

    Follow the steps to improve the network speed
    • Go to Start then run.
    • In this window, enter gpedit.msc
    • Double Click on Computer Configuration
    • Go to Administrative Template
    • Then in network
    • Then QoS Planner Packages
    • And limit the bandwidth booking.
    • Select enable. Then enter the value 0%

    The Packet Scheduler limits the system to 20% of the bandwidth of a connection, but you can override this value by using this parameter.
    • 0

    Synology DS1513+ backed up to IoSafe N2 with integrated Synology DSM


     


    #4 ikon

    ikon

      HSS Elite Master

    • Donating Member
    • 12,268 posts

    Posted 13 August 2011 - 08:23 PM

    O.K. have some more info:

    found this

    Follow the steps to improve the network speed

    • Go to Start then run.
    • In this window, enter gpedit.msc
    • Double Click on Computer Configuration
    • Go to Administrative Template
    • Then in network
    • Then QoS Planner Packages
    • And limit the bandwidth booking.
    • Select enable. Then enter the value 0%
    The Packet Scheduler limits the system to 20% of the bandwidth of a connection, but you can override this value by using this parameter.

    thanks
    • 0

    If at first you don't succeed, do it like your mother told you.


    #5 Greg Welch

    Greg Welch

      HSS Champion

    • Donating Member
    • 458 posts
    • LocationLas Vegas, NV

    Posted 14 August 2011 - 10:31 PM

    just as a referance lets compare. when it asks choose a 5000 mb file for your test

    totusoft.com also this was run from a client to server
    Posted Image

    Edited by welchwerks, 14 August 2011 - 10:32 PM.

    • 0

    Synology DS1513+ backed up to IoSafe N2 with integrated Synology DSM


     


    #6 Cino

    Cino

      HSS Member

    • Members
    • 38 posts

    Posted 15 August 2011 - 09:16 AM

    another thing you can try is do a search for TCPOptimizer http://www.speedguid...t/downloads.php and select optimal settings, Also change the NICs speed to max. It will tweak your NIC registry settings. I've had a lot of success with it on all my windows boxes. I does make a backup so you can go back.

    Edited by Cino, 15 August 2011 - 09:16 AM.

    • 0

    #7 Greg Welch

    Greg Welch

      HSS Champion

    • Donating Member
    • 458 posts
    • LocationLas Vegas, NV

    Posted 15 August 2011 - 02:21 PM

    That looks interesting, im downloading it now. i imagine ill need to try it on both server and workstation to open both ends up
    • 0

    Synology DS1513+ backed up to IoSafe N2 with integrated Synology DSM


     


    #8 ikon

    ikon

      HSS Elite Master

    • Donating Member
    • 12,268 posts

    Posted 16 August 2011 - 06:00 AM

    Also change the NICs speed to max. It will tweak your NIC registry settings.

    I would add the caveat that sometimes you have to leave the speed & duplex set at Auto, depending on which make & model of Ethernet switch is being used. For example, many of the dark blue Netgear switches won't play nice if you force your NIC to a specific speed & duplex.
    • 0

    If at first you don't succeed, do it like your mother told you.


    #9 Cino

    Cino

      HSS Member

    • Members
    • 38 posts

    Posted 16 August 2011 - 10:52 AM

    I would add the caveat that sometimes you have to leave the speed & duplex set at Auto, depending on which make & model of Ethernet switch is being used. For example, many of the dark blue Netgear switches won't play nice if you force your NIC to a specific speed & duplex.


    This setting is has nothing to do with the layer 1 speed/duplex of the NIC. But for the program itself so it can pick the optimal setting for your connection. In the past when you only had or 2 computers in the house, you would select the speed for your internet connect. With broadband and home networks, you can max this setting for the optimal settings for your NIC...

    But as you said, you should leave the NIC speed/duplex at auto. Or set the same setting on both the NIC and the switch.

    Edited by Cino, 16 August 2011 - 10:56 AM.

    • 0

    #10 ikon

    ikon

      HSS Elite Master

    • Donating Member
    • 12,268 posts

    Posted 16 August 2011 - 11:02 AM


    This setting is has nothing to do with the layer 1 speed/duplex of the NIC. But for the program itself so it can pick the optimal setting for your connection. In the past when you only had or 2 computers in the house, you would select the speed for your internet connect. With broadband and home networks, you can max this setting for the optimal settings for your NIC...

    But as you said, you should leave the NIC speed/duplex at auto. Or set the same setting on both the NIC and the switch.

    You've confused me. So you're NOT talking about the adapter settings in Local Area Connection Properties (in Win7 at least)?
    • 0

    If at first you don't succeed, do it like your mother told you.


    #11 timekills

    timekills

      HSS Advanced

    • Donating Member
    • 830 posts
    • LocationFort Bliss (hah), Tejas

    Posted 16 August 2011 - 01:55 PM

    I'm not a huge fan of the TCP Optimizer, and not because I'm a Luddite. Some - many - of the "tweaks", even those supposedly for Win7 or that kernel family are still throwbacks to XP and earlier. Much as people still thought many of the reghacks and service disabling that helped Win2000 and XP were still relevant in Win7 but at best do nothing and at worst can impede speeds. This is from my own testing, admittedly, but I saw connectivity lag when using the TCP Optimizer across my own LAN. It may have helped my Internet connection, but nothing measurable, and I had distinct issues across the LAN.

    For reference, these are connection speeds between a laptop - read only 5400 RPM hard drive - and my server:

    First one is before the registry change (i.e. the standard 20% limit for QoS):
    Posted Image

    This second one is after implementing the change on both laptop and server:
    Posted Image

    Not a significant difference. I caution you - QoS is just that. the 20% reserved does NOT mean it isn't used on a normal basis. What it means ifs under multiple measured streams the OS will portion out bandwidth to ensure the data type (or port, depending on your QoS) that requires higher priority (i.e. VIDEO, or voice - real time data requirements) are getting the bandwidth they need. By removing this you are allowing a Twitter pic or email download to over-ride or at best have equal time with the real-time data you want to prioritize.

    I.E. you are hurting your video streaming, not helping it. Stutter isn't caused by lack of bandwidth. Giving that extra bandwidth out and not allowing QoS may - may - help when you're transferring a 4+GB file across the LAN as long as no other network transmission is going on. But you'll be disappointed when your other data streams are competing and the video loses out because QoS isn't implemented or able to be measured.

    Be careful what you fix.

    P.S. posting non-addressble IPs - i.e. 192.168.x.x - isn't a security risk. MAC addresses aren't either really, but for those of you outside my house with a sniffer I'd rather you figure out which MACs are mine instead of me giving them to you. :)

    P.P.S I do agree with the jumbo frames if they are fully supported however. Again, do some checking because if any link doesn't support them, then the fragmentation caused by trying to use them will be much worse than not using them at all.

    Edited by timekills, 16 August 2011 - 02:01 PM.

    • 0

    #12 ikon

    ikon

      HSS Elite Master

    • Donating Member
    • 12,268 posts

    Posted 16 August 2011 - 08:31 PM

    P.P.S I do agree with the jumbo frames if they are fully supported however. Again, do some checking because if any link doesn't support them, then the fragmentation caused by trying to use them will be much worse than not using them at all.

    Totally agreed. The really fortunate thing is it is extremely easy to test, and trivial to disable if no benefit is seen.
    • 0

    If at first you don't succeed, do it like your mother told you.


    #13 Mr_Smartepants

    Mr_Smartepants

      HSS Champion

    • Members
    • 352 posts

    Posted 17 August 2011 - 03:05 PM

    Well I had the opposite experience. Enabling jumbo frames killed my backups. Backups would get to about 50% and then kill the server network connection on my WHSv1 EX490. The connector icons would turn grey on all my client PCs and I'd have to do a manual shutdown (hold the power button for 2 sec.) just to restore connectivity.
    • 0

    HP EX490 (E5200 CPU & 4GB RAM upgrades) WHS2011. HP N54L Microserver (4GB RAM) WHS2011.

    DriverPacks.net Administrator and Team Lead. Some heroes don't wear capes, they wear dog-tags & Kevlar!
    Stand-Alone Driver Disk (SAD2) update utility for DriverPacks.net (installs drivers automatically on all versions of Windows from 2000 to 2012).


    #14 ikon

    ikon

      HSS Elite Master

    • Donating Member
    • 12,268 posts

    Posted 17 August 2011 - 03:12 PM

    Well I had the opposite experience. Enabling jumbo frames killed my backups. Backups would get to about 50% and then kill the server network connection on my WHSv1 EX490. The connector icons would turn grey on all my client PCs and I'd have to do a manual shutdown (hold the power button for 2 sec.) just to restore connectivity.

    Sorry to hear that. Mine still seem to be working, but I think I'll do a manual one just to confirm, so thanks for posting. Out of curiosity, did you try all the different Jumbo Frame sizes and, assuming you did, did you notice any difference at all?
    • 0

    If at first you don't succeed, do it like your mother told you.


    #15 dvn

    dvn

      HSS Elite

    • Moderators
    • 1,735 posts

    Posted 17 August 2011 - 03:44 PM

    The Packet Scheduler limits the system to 20% of the bandwidth of a connection, but you can override this value by using this parameter.

    Correct me if I'm wrong, but I believe this only comes into play when you use QoS. Otherwise, it does nothing.

    I agree with timekills about TCPOptimizer. I also feel it is vestige of XP days, and even then it did not benefit a system that was configured with the default network settings. Now if some application had badly messed with the settings, then TCPOptimizer might provide some improvement. That was my experience, anyway.
    • 0

    #16 Greg Welch

    Greg Welch

      HSS Champion

    • Donating Member
    • 458 posts
    • LocationLas Vegas, NV

    Posted 17 August 2011 - 06:09 PM

    correct, i ran across another post stating the QOS improvement, i also after tryingTCPoptimizer felt the same way and sticking with manual adjustments
    • 0

    Synology DS1513+ backed up to IoSafe N2 with integrated Synology DSM


     


    #17 Cino

    Cino

      HSS Member

    • Members
    • 38 posts

    Posted 17 August 2011 - 08:40 PM

    I suggest TCPOptimizer as it was a quick for my system. After building my WHS 2011 box I started to test SMB and NFS shares to my WDTV Live device. 1-2GB AVIs and MKV would stutter over NFS but were playable over SMB (should be the other way around). I have a couple of 16GB+ MKV files and they would stutter after a minute of playing. ISOs would take a minute to start playing. Before building the WHS box, all my movies would play over a NFS share from my single drive QNap NAS with no issues, AVIs, MKV, ISOs(I had stuttering with SMBs). Thinking it was the built-in Realtek NIC, I popped a Intel Server 1000 NIC in the box and had the same results.

    I hard set my NICs/Switch Port speed, didn't help. I used a cross-over cable between WHS and my WDTV box, no luck. Also thought about JUMBO frames but knew this could cause issues with parts of my network. We do use JUMBO frames on certain networks at work but they are on networks that are just for video streaming, think VoD or MoD. I never gave TCP Optimizer a thought as I agree that its from the good old XP days and previous windows OSs. I decided to try it and it was night and day for me. No stutter on either SMB or NFS shares.

    When I remove the setting, stuttering comes back...I would prefer not to use it but it works for me on my WHS box. What I need to do is find the time and figure out what setting(s) it change that fix the stuttering for me.

    I haven't messed around much with Win 7 built in QoS but if your internal network isn't setup for it, is there any benefit? Even if I did setup DSCP or 802.1p on my switch, i'm accessing my Videos via a SMB or NFS share. I could be wrong but I don't believe windows would tag the packets to increase or decrease the traffic priority. Maybe if I used DLNA it would tag the packets.
    • 0

    #18 ikon

    ikon

      HSS Elite Master

    • Donating Member
    • 12,268 posts

    Posted 17 August 2011 - 08:44 PM

    interesting Cino
    • 0

    If at first you don't succeed, do it like your mother told you.


    #19 Mr_Smartepants

    Mr_Smartepants

      HSS Champion

    • Members
    • 352 posts

    Posted 17 August 2011 - 11:50 PM

    Out of curiosity, did you try all the different Jumbo Frame sizes and, assuming you did, did you notice any difference at all?

    Yes. My desktop only supports up to 7k MTU sizes so that's what I started with on the EX490, then 5k & 4k MTU before I gave up and switched back to "Disabled".
    I still have Jumbo frames enabled on my desktop NIC set at 4k but it's disabled on the server. Backups now complete normally.
    My gigabit switch supports Jumbo frames up to 9k MTU but I'm not sure of my router (Linksys WRT320N).
    • 0

    HP EX490 (E5200 CPU & 4GB RAM upgrades) WHS2011. HP N54L Microserver (4GB RAM) WHS2011.

    DriverPacks.net Administrator and Team Lead. Some heroes don't wear capes, they wear dog-tags & Kevlar!
    Stand-Alone Driver Disk (SAD2) update utility for DriverPacks.net (installs drivers automatically on all versions of Windows from 2000 to 2012).


    #20 ikon

    ikon

      HSS Elite Master

    • Donating Member
    • 12,268 posts

    Posted 18 August 2011 - 06:23 AM

    Yes. My desktop only supports up to 7k MTU sizes so that's what I started with on the EX490, then 5k & 4k MTU before I gave up and switched back to "Disabled".
    I still have Jumbo frames enabled on my desktop NIC set at 4k but it's disabled on the server. Backups now complete normally.
    My gigabit switch supports Jumbo frames up to 9k MTU but I'm not sure of my router (Linksys WRT320N).

    Interestingly, I have noticed that my network just seems a little more 'peppy' since enabling Jumbo. Of course it's subjective and hard to quantify, but things just seem to respond a bit quicker. I noticed it particularly when connecting to my Untangle UTM; the usual lag for the main page to come up wasn't there. Still haven't done the backup test.... must do that.
    • 0

    If at first you don't succeed, do it like your mother told you.





    Skins By Invisioneers