rheo

WHS 2011 - rdp remote access

43 posts in this topic

i am running windows home server 2011. I have the remote access web interface working and can successfully connect to my client computers via remote desktop by clicking on the icon from the web interface. works great.

 

is there a way to connect to the actual windows home server or indeed other hosts running windows server 2008 r2 using this ts gateway?

Share this post


Link to post
Share on other sites

i am running windows home server 2011. I have the remote access web interface working and can successfully connect to my client computers via remote desktop by clicking on the icon from the web interface. works great.

 

is there a way to connect to the actual windows home server or indeed other hosts running windows server 2008 r2 using this ts gateway?

 

One of the RDP icons should be the WHS; if nothing else it at least should appear. I can remote into my Server 2K8R2 because my WHS2011 is a virtualized OS on the Server 2k8R2 host, and I've installed the connector on the host. Yes, the host is connected to the guest server, but that allows just what you are asking - RDP via web interface into the host OS.

 

EDIT: I slap myself - the "RDP" into the WHS is simply the Dashboard access. I forgot I used the RDP into the Server2K8R2, and then accessed the WHS 2011 via Hyper-V manager from there. So the RDP in Server 2K8R2 via WHS 2011 is fine, but to itself is Dashboard access only.

Edited by timekills

Share this post


Link to post
Share on other sites

Great. my whs 2011 is running in hyper-v too. i didn't know i could install the connector software on the windows server 2008 r2 host. i will try it! thanks

 

Tim

Edited by rheo

Share this post


Link to post
Share on other sites

I used to install the connector software from my virtualized WHSv1 on the Server 2008R2 host; I didn't originally install the connector software from WHS 2011 into the host since I could just access the shared drives until I realized it made for a relatively easy web access doing exactly what you are asking. It does tell you that it is "not supported" but it will work, if you don't mind installing the .NET 4.0 bloatware. I had to access it via the "connect to more computers" link since the main page only shows three systems including the WHS 2011 box, but when you click that link I get the choices in the image below:

 

RmtDsktp_Server2K8R2_host_via_WHS2011_as_guest%20%281%29.png

 

I blacked out the names but you can plainly see the Windows Server 2008 R2 Standard as the second (and available!) choice.

Edited by timekills

Share this post


Link to post
Share on other sites

What, W7 Home Premium is not supported for backups? That is crazy.

 

Why not just remote into one of the desktops and then RDP from the desktop into the server? Another option, which would be better if it works, is to install Windows Live Mesh on s2008r2.

Share this post


Link to post
Share on other sites

What, W7 Home Premium is not supported for backups? That is crazy.

 

Why not just remote into one of the desktops and then RDP from the desktop into the server? Another option, which would be better if it works, is to install Windows Live Mesh on s2008r2.

It IS supported for backups, but not for remote access. I agree it's rediculous; they call it Windows Home Server but you can't remote into Windows 7 Home Premium. Lunacy.

Share this post


Link to post
Share on other sites

I didn't catch the backup part. It is still crazy though.

To Quote Francis Urquhart, "you might very well think that. I couldn't possibly comment"

Share this post


Link to post
Share on other sites

You can adjust WHS2011 to allow you direct RDP access to the server rather than the desktop by modifying a reg setting, details here:

 

http://blog.djmatty.com/?p=366

 

Cheers

 

Matt

This is confusing me. When I RDP into my WHS2011 it always takes me to the desktop, always has. There is a disclaimer on the desktop stating that I shouldn't use the computer for general computing, but I get that when I'm working directly on the WHS as well. I don't recall ever having the Dashboard come up automatically.

Share this post


Link to post
Share on other sites

@ikon, if you use the Remote Web Access site via the internet to 'connect' to the home server machine itself (not one of the client computers) the default RDP session it creates will only show the dashboard app, rather than the server desktop. The reg setting will disable that 'feature' and connect directly to the desktop of the server. This means you do not have to open the RDP ports through the firewall onto the internet, as the server uses RDP over http for those sessions.

 

You, I assume, are using the rdp client directly to the server, which will connect you directly to the desktop.

Share this post


Link to post
Share on other sites

I believe everyone is referring to the RDP connection from the Dashboard. A normal RDP connection through Term Services would take you to the remote desktop. I do know the RDP connection from the SBS 2011 (not essentials) will act like a true RDP connection.

 

I need to look at that Registry Entry and see what the properties are.

Share this post


Link to post
Share on other sites

To save a bit of time, i'll post the important bit of the info here :)

 

"After using dotpeek to dig around in the rdp assemblies, I noticed that it is checking a reg value when it builds the rdp file, and if the value is not set (or is 0) it adds an app alias to the dashboard. The name of this value is “EnableServerRemoteDesktop”. So, I opened reg edit and added a DWORD value at “HKLM\Software\Microsoft\Windows Server\RDP” with the aforementioned name, and set it’s value to 1, and reconnected to the WHS machine from the remote web page."

Share this post


Link to post
Share on other sites

@ikon, if you use the Remote Web Access site via the internet to 'connect' to the home server machine itself (not one of the client computers) the default RDP session it creates will only show the dashboard app, rather than the server desktop. The reg setting will disable that 'feature' and connect directly to the desktop of the server. This means you do not have to open the RDP ports through the firewall onto the internet, as the server uses RDP over http for those sessions.

 

You, I assume, are using the rdp client directly to the server, which will connect you directly to the desktop.

Annnnd, my confusion is cleared up. Thx. I never use the web access feature; didn't use it on v1 either. I looked at it, but that was all; couldn't see the point of it really when I have real RDP available.

Share this post


Link to post
Share on other sites

@ikon, yeah if you have the rdp ports opened through the firewall it's less necessary... but with WHS2011 its great for rdp access when you are behind a proxy/firewall that doesn't allow anything other http/https (like my work), I can still rdp into all my boxes at home via the remote web access site.

 

Before WHS2011, i had to use some arcane SSH magic to tunnel rdp sessions through HTTPS to my server :)

Share this post


Link to post
Share on other sites

@ikon, yeah if you have the rdp ports opened through the firewall it's less necessary... but with WHS2011 its great for rdp access when you are behind a proxy/firewall that doesn't allow anything other http/https (like my work), I can still rdp into all my boxes at home via the remote web access site.

 

Before WHS2011, i had to use some arcane SSH magic to tunnel rdp sessions through HTTPS to my server :)

 

Sounds painful. At work I can use RDP and, by the time they get around to changing it, I'll probably be retired ;)

Share this post


Link to post
Share on other sites

The Problem for me was:

Being that ‘Server Manager’ is the biggest set up option in the WHS software I used it to set up the users in a somewhat geeky and correct way I thought.

However there is a bug. Users set up in Server Manager is not seen in ‘Dashboard’. If one tries to setup the users in Dashboard, not seen in Dashboard, entered in Server Manager, it won’t let you because it tells you thoses users are already existing – even though they cannot be seen in Dashboard.

 

The answer is delete them from Server Manager and reset them up in Dashboard – Remote Web Access then worked fine for me.

Share this post


Link to post
Share on other sites

I guess that's why they have that warning post on the desktop of the default RDP screen :)

Share this post


Link to post
Share on other sites

Not seen that!

Really? You should see it if you RDP into the WHs2011 directly (not via the web). Right in the middle of the desktop wallpaper, which is very light blue, is white text on a bit darker blue that says not to use the server for general purposes.

Share this post


Link to post
Share on other sites

Well of course, that goes without saying, that is clear. However this issue occurred in the set up procedure which is not a 'general use' issue. it is a bug and I will report to Microsoft via Technet in due course. There's no way that one part of the software should not talk to another part, especially when so fundamental. WHS is a fantastic concept, but it needs some work by MS to perfect it.

Share this post


Link to post
Share on other sites

Ah, I must have misunderstood. No insult intended.

Share this post


Link to post
Share on other sites

I just now came across this problem after deploying WHS 2011 in town last week, miles from me of course. Can someone tell me if the remote machines wan ip is enough to connect to the whs 2011 machine? I have full admin rights, one normal user account for myself and also get the Dashboard when I try to connect using the Remote Web Access feature. I tried using RDC from my Windows 8.1 machine at home but it keeps telling me the machine is not connected or turned on, which I know is false.

 

So what is the proper syntax for the Computers RDC url below? Just the external IP and port 3389? And do I use the admin account that I used to build the machine or the user account I created for myself in the Dashboard? I expected the server to have RDP enabled by default so is this not the case? Lol, do I need to take that 30 mile trip to my server to fix this oversight?

3zuj4kc.jpg

 

Sorry if this is obvious but I have tried everything, the IP and port, the domain name, everything and either I have the format wrong or the firewall is blocking RDP. If the firewall is blocking RDP why can I access the Admins Dashboard which is also using RDP?

 

Any tips would be helpful. This is the first time I am managing a WHS 2011 server from outside a Network. My other servers are all within my home network and work great with RDP. I just do not remember what I did to set it up as its been a few years now.

 

Thank You!

Rod

Share this post


Link to post
Share on other sites

To get direct RDP to work externally you will need to ensure that the network router has port 3389 forwarded to the server, so that all traffic on port 3389 from the internet to the WAN IP gets forwarded to your server. You may also need to open that port (or enable rdp) through windows firewall on the server. This should then allow rdp traffic to the server direct from the internet.

 

The admin dashboard does use RDP, however it uses it through 'RDP over HTTP' service which allows the rdp session via HTTP over port 443. As a security feature the default is only to allow dashboard access to the server via RDP. You can change this by changing the registry setting as detailed here http://blog.djmatty.com/blog/post/2011/06/16/Windows-Home-Server-2011-and-RDP-direct-to-desktop-of-the-server.aspx

 

Sorry, but I would say that you will probably need to make the trip to the server to make the changes (either the registry change, or the firewall/router changes to open the RDP port to the internet) so that you can access the server remotely. (I would recommend just making the registry change, rather than opening up RDP direct to the internet though)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now