Jump to content


Photo

Windows Server 2016 on HPE ProLiant ML30 Gen9

s2016 hpe ml30 gen9 proliant

  • Please log in to reply
No replies to this topic

#1 Joe_Miner

Joe_Miner

    HSS Legend

  • Moderators
  • 3,500 posts
  • LocationNorth East Ohio

Posted 17 March 2017 - 03:42 PM

After the installation of the ToughArmor MB994SP-4SB-1 I used iLO4 to remote into my ML30 Gen9 and began to install Windows Server 2016 manually (i.e. without using IP) http://homeserversho...ml30-gen9.html 

 

I updated the Firmware with SPP then installed S2016 then updated the drivers with HPSUM.

 

Figure009.jpg

 

Figure010.jpg

 

Figure011.jpg

 

 

Figure012.jpg

 

Figure013.jpg

 

Figure014.jpg

 

 

Updating Firmware, installing Windows Server 2016, Updating Drivers

I used iLO4 to remote into my ML30 Gen9 and began to install Windows Server 2016 manually (i.e. without using IP) in the following general steps:

 

  1. Download Service Pack for ProLiant (SPP) from Hewlett Packard Enterprise Support Center – Drivers & Software – the current version is 2016.10.0 (24 Oct 2016) – check also treads about SPP at HSS Forum MS Gen8
  2. Load the SPP ISO in remote desktop of iLO4
  3. Boot the ML30 Gen9 – with no drives in the ML30 Gen9 in my case – and let SPP run automatically and update all firmware
  4. Shut down the ML30 Gen9
  5. Next: I loaded the Samsung 840 Pro 256GB into drive 1 of the Icy Dock ToughArmor MB994SP-4SB-1
  6. Go to the Hewlett Packard Enterprise Support Center – Drivers & Software – and download the file cp028631.exe that is the Dynamic Smart Array B140i Controller Driver for 64-bit Microsoft Windows Server 2012/2016 Editions (This is the same driver I plan to use for a manual installation of Windows 10 64-bit Pro sometime later in the ML30 Gen9) – the current version is 62.12.0.64 (24 Oct 2016)
  7. Extract the files in cp028631.exe and load those into a file folder that I then attach/load in remote desktop of iLO4 (during Windows install this will be the folder I browse to so that Windows can pull in the driver and see the Samsung 840 Pro
  8. Load the Windows Server 2016 ISO in remote desktop of iLO4
  9. Boot the ML30 Gen9
  10. During boot go into IP and select SSA (Smart Storage Administrator)
  11. In SSA I set up the Samsung 840 Pro as a single drive RAID0 to be used as my OS drive
  12. Exit SSA & IP and Restart the ML30 Gen9
  13. Proceed with the normal Windows install
  14. After Windows is installed and updated – reattach SPP ISO in remote desktop of iLO4
  15. In the Windows desktop go to the SPP ISO in File Explorer and Execute the Batch file for HPSUM – I chose the automatic update
  16. After running HPSUM (and rebooting) the HPE software shown in Figure above was installed.  Enjoy!

Edited by Joe_Miner, 17 March 2017 - 03:47 PM.

WHS-2011: HAF932,X58A-UD3R,i7-930, 12GB, HD6450, R640L, Corsair GS240GB, 5in3FatCage, 3*DuoSwap, 5*Red4T+1*Red3T, DrivePool&Scanner-|-  CrashPlan -|-
HTPC1 W10P: NUC6i5SYH 16GB DDR4 2133 HX421S13IBK2/16, 500GB Samsung 850 EVO M2 SATA III -|- 

HTPC2 W10P Gen8 MS E3-1265LV2,ECC KVR1333D3E9SK2/16G, SDM, OS: Corsair GT240GB RAID0; HD6450 -|- 

Desktop W10P: Lian-Li PC-K9WX,Z77X-UD5H, i7-3770,32GB-RAM,OS-SamPro840-256SSD, ST3000DM001 -|-
LAB: W10P: GD05B, Z68MX-UD2H-B3, i5-2500K, 16GB G.Skill, CorsairGTX240GB, VR -|- W10Pro; HPE ML30 Gen9 Xeon E3-1240v5 MB994SP-4SB-1, 8GB, -|- W10PN40L ECCKVR1333D3E9SK2/8G, HD5450,R620L,256GB Crucial M4 -|- 

LAB: W8.1p HP ML10v2 E3-1220v3 ECC KVR16E11K4/32, OS: Corsair GT240GB, P222/512FBWC 4*5TB RAID5, 4*1TB RAID10, Samsung 840 Pro SSD, MB326SP-B, 686745-002  -|-

LAB: Laptop W10P: Acer 1810T, 4GB RAM, 256GB Crucial M4-|- HP Stream 7 W10 -|- Raspberry Pi 2 -|- DragonBoard 410c -|- Surface 3 W10 -|- Router: DIR 890L/R -|- MB7420






Also tagged with one or more of these keywords: s2016, hpe, ml30 gen9, proliant